• 0

DMS 2 Menu indicators & Web URL


Question

Posted · Report post

Question?

 

Web viewing and menu indicators do not show up when adding a www in front of my url?

 

Suggestions?

 

http://bit.ly/1umjnRq

Screen shot attached.

 

[attachment=2408:menu-inducatir.png]

Share this post


Link to post
Share on other sites

11 answers to this question

  • 0

Posted · Report post

Thats because when the CSS was compiled, you were logged into NON-WWW.

 

You must choose which one you are going to use, and redirect from the other. Non redirected www means you have 2 websites, google will penalize you.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Is that a DNS issue? from the host and name servers?

 

A.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

No, its up to you to decide whether to use www or not, then setup a htaccess file to handle it.

 

If you are going to just use www, make sure www is in the URLS in wordpress settings.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Simon thanks for helping with this... as never had to deal with it before...

 

ok... so we have no www. access in wordpress settings...

 

host is set up without the www.  and that is what we were told to use..

 

what would we need to add to the htaccess?

 

A.

 

 

 

 

Share this post


Link to post
Share on other sites
  • 0

Posted (edited) · Report post

RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
Edited by Simon_P
wrong code

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Wow...

 

why did I not have to do this before?????

 

Is this standard?

 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

updated with right code

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Wow...

 

Is this standard?

 

Never had to mess with the .htaccess for a redirect before.

 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Depends how your host is setup.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

OK thanks...

 

 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Simon_P

 

So... there was a problem with the clients internal server....

and we now had to set the wordpress settings to www...

 

How would I re-write that redirect code from what you sent me:

 

RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ http://%1/$1 [R=301,L]

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now