Jump to content


Photo
- - - - -

Framework Page Options won't save, causes 404

Page Options

  • Please log in to reply
10 replies to this topic

#1 idea15

idea15

    Advanced Member

  • Members
  • 58 posts
  • Country: Country Flag

Posted 11 August 2014 - 11:54 AM

Hi - if I go to Pagelines --> Page Options and try to make any changes, when I click on Save Options, it goes to a 404 page, /wp-admin/options.php.

 

So for example, all I'm trying to do is set the Tag Listing pages to have a left-hand body column and one right sidebar. Can't do it.

 

I have tried deactivating all plugins. No change.

 

I don't have the Pagelines Section plugin or any Pagelines sections installed.

 

This is why I've always referred to Pagelines as my gifted child. It's great with the advanced stuff, but try to do something simple and you end up here on the Forums.

 

Debug info:

(provided)



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 16342 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 11 August 2014 - 12:08 PM

Hi,

 

Would it be possible for you to disable all plugins and then record your issue using one of the following applications please.

 

QuickCast

Jing

When recording please go to your plugins page so we can make sure all are disabled, then proceed to demonstrate the error. From here, we can attempt to recreate it.



#3 idea15

idea15

    Advanced Member

  • Members
  • 58 posts
  • Country: Country Flag

Posted 11 August 2014 - 12:18 PM

Hope this suffices.

Please Login or Register to see this Hidden Content



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 16342 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 11 August 2014 - 12:40 PM

Who is your host and what is the Drop-in that is listed on your Plugins page. As I have just changes the page layout on the tag listing template, clicked save and the setting was saved, no issue for me nor any 404.

 

The issue may be related to your host environment, as you also have this - PHP User : Posix functions are disabled on this host!

 

Which may be causing the issue.



#5 idea15

idea15

    Advanced Member

  • Members
  • 58 posts
  • Country: Country Flag

Posted 11 August 2014 - 12:47 PM

The host is Krystal and the drop-in is advanced-cache.php, which is part of WP Super Cache.

 

What do I need to tell Krystal to do?



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 16342 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 12 August 2014 - 08:50 AM

I am not entirely sure, as I am unable to recreate the issue. Unfortunately, I am unable to provide a video demonstrating that I am unable to recreate it, as I am using the Yosemite beta (OSX) and QuickCast and Jing are working as intended.

 

Can you provide a link to the site in question and make sure debug is enabled please, as your debug info is no longer in the topic. Also, enable WP_DEBUG and see if there are any notices or errors. Another thing to do is when you're on the tag listing options page, open your browsers console and see if there are any errors.

 

I also did a reverse IP check on your domain and there are over 400 other websites running on the same server your as domain. This means that you're using shared hosting, which also means that it is very likely your host has configured the server in such as way, which is causing this issue. Especially, see as how I am unable to do so when trying to replicate it on my local host.



#7 idea15

idea15

    Advanced Member

  • Members
  • 58 posts
  • Country: Country Flag

Posted 12 August 2014 - 09:22 AM

Debug info is

Please Login or Register to see this Hidden Content

 

This forum is not allowing me to attach the debug log generated during the issue, but all it is is messages relating to plugins and deprecated functions. The problem persists even when all plugins are deactivated.

 

The only entries in the debug log pertaining to Pagelines are

[12-Aug-2014 09:02:44 UTC] PHP Notice:  Undefined offset: 0 in /home/ideawebd/public_html/wp-content/themes/pagelines/admin/class.rss.php on line 98
[12-Aug-2014 09:02:44 UTC] PHP Notice:  Undefined offset: 1 in /home/ideawebd/public_html/wp-content/themes/pagelines/admin/class.rss.php on line 99
[12-Aug-2014 09:02:44 UTC] PHP Notice:  Undefined offset: 0 in /home/ideawebd/public_html/wp-content/themes/pagelines/admin/class.rss.php on line 98
[12-Aug-2014 09:02:44 UTC] PHP Notice:  Undefined offset: 1 in /home/ideawebd/public_html/wp-content/themes/pagelines/admin/class.rss.php on line 99
[12-Aug-2014 09:02:44 UTC] PHP Notice:  Undefined offset: 0 in /home/ideawebd/public_html/wp-content/themes/pagelines/admin/class.rss.php on line 98
[12-Aug-2014 09:02:44 UTC] PHP Notice:  Undefined offset: 1 in /home/ideawebd/public_html/wp-content/themes/pagelines/admin/class.rss.php on line 99
[12-Aug-2014 09:02:44 UTC] PHP Notice: A feed could not be found at

Please Login or Register to see this Hidden Content

. A feed with an invalid mime type may fall victim to this error, or SimplePie was unable to auto-discover it.. Use force_feed() if you are certain this URL is a real feed. in /home/ideawebd/public_html/wp-includes/class-simplepie.php on line 1580
[12-Aug-2014 09:02:45 UTC] PHP Notice: A feed could not be found at

Please Login or Register to see this Hidden Content

. A feed with an invalid mime type may fall victim to this error, or SimplePie was unable to auto-discover it.. Use force_feed() if you are certain this URL is a real feed. in /home/ideawebd/public_html/wp-includes/class-simplepie.php on line 1580
[12-Aug-2014 09:02:45 UTC] PHP Notice: A feed could not be found at

Please Login or Register to see this Hidden Content

. A feed with an invalid mime type may fall victim to this error, or SimplePie was unable to auto-discover it.. Use force_feed() if you are certain this URL is a real feed. in /home/ideawebd/public_html/wp-includes/class-simplepie.php on line 1580

 

The only error generated in the console during this issue is

 

SyntaxError: missing ; before statement options.php (line 102, col 3)
to place your webfonts in a custom directory, uncomment this an

If this problem is not solvable, I need a workaround. I should not have to enable three different debugging functions and ask a host to reconfigure a server so that I can set a page layout.



#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 16342 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 12 August 2014 - 11:46 AM

Of course you shouldn't have to enable all these different debug options. However, the likely cause is your host, as I mentioned above, I am not able to recreate your issue. If you can PM your admin username/password and URL I will take a closer look.



#9 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 12 August 2014 - 02:21 PM

The issue is either mod security plugin or max input vars needs to be increased in php ini
  • Danny likes this

#10 idea15

idea15

    Advanced Member

  • Members
  • 58 posts
  • Country: Country Flag

Posted 15 August 2014 - 06:33 AM

And obviously as I can't access or change the settings on either, what is my workaround?



#11 Danny

Danny

    Is Awesome!

  • Moderators
  • 16342 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 August 2014 - 12:29 PM

You will want to contact your web host provider and ask them to do it for you.







Also tagged with one or more of these keywords: Page Options