• 0

DMS 2 Media not displayed on RTL page


Question

Posted · Report post

Dear Pagelines team, I have set up a bilingual website, with a WPML language switcher. The result is that I have one set of LTR pages (for English) and one set of RTL pages (for Arabic). Everything works well, I can edit the page (the old problem with the Editor in RTL has been solved!), the text appears correctly. But images don't show up! I can upload them, enter them in a Media Box, but they don't appear on the page, no matter how often I save changes and refresh. You can see the result here: http://animatinglibraries.com/wordpress/?lang=ar. Inside of sections and plugins (Flyp from the Pagelines Store and Justified Image Grid, a gallery plugin) images are still shown. But through the usual Pagelines ways I cannot get them at all. Have you any idea what may be amiss? I am very grateful for your care!

Yours faithfully, Jan.

Share this post


Link to post
Share on other sites

12 answers to this question

  • 0

Posted · Report post

Could you enable debug for us please on your sites and we will be able to look into this. 

 

Apologies this topic seems to have gotten missed as you replied to it yourself. It's better to edit your own topics rather than reply. 

 

Also, When creating a topic you are asked for the following info which we need to help - please could you provide the following 

 

Remember to include as much information about your technical issue as possible for example:
Website URL:
Framework Version:
WordPress Version:
Plugins in Use:
Server/Host:
Screenshots:
Details:

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Dear Martin, the thought of having confused things with my own reply also occurred to me and made me open a new topic. I'm glad to be in good hands now!

I am using DMS 2.1.1. and WordPress 3.9.1. and an assortment of plugins, mostly from the Pagelines store. But I already tried deactivating everything - including the Pagelines plugins - to no avail. 

I just set up DEBUG, it does indeed show up something though I'm not sure if it's relevant to the problem. You'll know better!

Notice: wpdb::prepare was called incorrectly. The query argument of wpdb::prepare() must have a placeholder. Please see Debugging in WordPress for more information. (This message was added in version 3.9.) in /web/1/000/072/094/296115/htdocs/animatinglibraries/wordpress/wp-includes/functions.php on line 3245

I am away now for a few hours and will only be able to return to this myself tomorrow morning. In any case I am grateful that you are having a look at it and hope that it can be solved somehow soon! Yours faithfully, Jan.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Plugins: 

BigTextDMS PL Section

Custom Post Type UI

DMS Professional Tools

Enhanced Options Editor

Filtering

Flyp PL SectionFormidable

Grid Shortcodes

Justified Image Grid

Meta Box

PageLines Updater

Scroll Nav DMS

Testimonials Lud DMS

TinyMCE Advanced

UpdraftPlus - Backup/Restore

WPML Multilingual CMS

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hello again. I managed to resolve the issue that was flagged in Debug: "wpdb::prepare was called incorrectly. The query argument of wpdb::prepare() must have a placeholder." It turned out to be a known issue concerning an older version of WPML that struggled with a change in WP 3.9 regarding the handling of mysql queries. Now this is gone and Debug does not show anything, but there are still no images. I cannot upload new images (or rather, I can upload them, they register in the Editor but they don't show) and if I want to take an image from the Media Library, there are no items shown. Switching back to the LTR page, the Media Library works as usual and everything shows up. I hope you have an idea what might be going on... Yours faithfully, Jan.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Just in case this might be relevant information: Here you can see the invisible images in action. During editing in Chrome, the images are replaced with a broken image icon - when not logged in these do not show). http://www.screencast.com/t/SrhbGZx4

 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Could you create an admin logon for your site and send the credentials to hello @ pagelines dot com along with a link for this topic and we will look deep into this for you. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hello Pageliners, I have not been able to find a solution. No images in RTL, unless they are inside a shortcode that's pasted into the Text and Embed HTML of a MediaBox. Did you have a chance to have a look at this, and can you make any sense of it? I look forward to hearing from you - I hope it will be possible to solve this - or better even that it's just me who is doing something wrong, though in spite of looking at everything thoroughly I cannot figure out what that would be at the moment. Yours faithfully, Jan.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Dear Pagelines team, did you have any luck in this matter? I appreciate your efforts and hope that this can be solved somehow. Yours faithfully, Jan.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

The issue is as far as I can tell, the URL of the image isn't correct, as it is adding the lang=ar to the image path which you can see here.

 

http://animatinglibraries.com/wordpress/?lang=ar%2Fwp-content%2Fuploads%2F2014%2F06%2FTamerWebsiteTransparentfiller.png

 

I recommend you contact WPML support for assistance, as I don't think this is related to DMS.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Dear Danny, thank you, this is very helpful indeed. I will contact WPML, now that I Knowledge what to ask for I hope they can sort this out. Tanks again, I will get back to you should there be new questions. Yours faithfully, Jan.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

No problem Jan and keep us posted.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now