• 0

Woo Commerce Sidebar Cutoff

Question

Posted · Report post

Sidebar is cutting off the edge of price slider and the price slider doesn't work on mobile.  Also the products in the cart don't show.  I've looked at a couple other DMS sites with Woo and they seem to have same issues.  How can I fix this?  Image is attached.  

 

http://screencast.com/t/uAESP0N6S2

Share this post


Link to post
Share on other sites

27 answers to this question

  • 0

Posted · Report post

New pro tools is released that fixes the lazy load issue with the sidebar cart images.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hello jmad - looking into this for you. 

 

Which device & OS are you viewing this on? 

 

Do you have a link to your site where this is a problem? 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Desktop is where it is cutoff.  The price slider doesn't work on an iphone5 and maybe it's just best not to show the slider but is there an option to list price ranges instead of slider in woo or is this part of DMS?  The site is behind the Flywheel password and client doesn't want it open yet.  However, I can message you the address and login/password.

 

Actually, I just messaged it to you.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks for the info. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Any word on this yet?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Martin Davies

 

Any word on this?  I need to get resolved.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

When we try to access the site we are met with an authentication window. Could you take a look at this for us please?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You should be getting the Flywheel login... I sent the login and password to hello@pagelines.

 

Are you getting something other than that?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

My Bad. I misread the password characters and the username you provided had a Capital. 

 

I can see the slider is being cut off.

 

The cart seems to be working though http://screencast.com/t/QMYeX1cq

 

The price slider does appear to not work. I have tried this on my test site and it does not work on iphone5. Thought this could this be that you have two prices/items in your shop items and two ends to the scale of the slider but it does  not work no matter how many prices. 

 

These components are Woo Commerce elements and need to be reported to WooCommerce support. in the meantime i will see if there is a temporary fix for these now until Woo come back to you on this. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Martin Davies

 

No worries.  The cart issue is not in the cart but the items already added to the cart on the product page or the shop page.  http://screencast.com/t/uAESP0N6S2

 

Yes, I agree about the price slider...just tested on another site using a different theme and the slider doesn't work on iphone5 or 4.

 

However, the cart images aren't cutoff in that theme/site so I think that might be DMS related.

 

Hope that helps.

 

Thanks again.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Have you managed to fix this? the slider is not being cut off anymore. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Haven't changed anything.  The Cart Items in the sidebar is still an issue.  The slider...you have to look really closely to notice but it's still happening or at least it was.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

http://screencast.com/t/Gz7S2SsTvHvz

 

Looks like it has stopped happening - there was a noticeable cutoff yesterday. 

 

 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Let's roll with it for now then.  The only thing my client really wants resolved is the product image in the Cart portion of the sidebar.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Any word on the product image being cutoff/absent in the Cart area of the side bar?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Martin Davies Any word on the Cart Items being cutoff in sidebar?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Are you guys researching this or what?  It's been a while and I haven't heard from anyone.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

If you disable DMS and enable TwentyFourteen does the same thing happen, as that is a Woo Widget and not a PageLines one.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

TwentyFourteen screws up everything and the custom sidebar is gone.  As I said though, in other themes I have installed and using WooCommerce it isn't happening.  I noticed in a few other DMS2 sites with Woo installed it is happening also.

 

I noticed the product images are displaying in your demos of iBlog and PinPro.  Also the "Related Products" image size isn't super large.  Are there recommended photo sizes for products when using Woo with DMS?  

 

I'm getting a bit frustrated with this as implementing Woo in other themes isn't typically this problematic with the little details.   

 

This is also still unresolved.

 

http://forum.pagelines.com/topic/35658-woo-commerce-related-products-image-size-and-text/?p=212537

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Danny

 

Please help me resolve this issue.  I'm a club member and according to http://www.pagelines.com/club/ we are supposed to get priority support times and deeper support.

 

I need this resolved to bring site live.  I tested on a blank DMS2 site and the issue exist...

 

How is the sidebar being implemented in your demos?  Which custom sidebar tool is being used and what size are the product photos loaded into Woo?  I'm using the free version of Custom Sidebars.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Priority support means that any club member created topics in the forum take precedence over over non-club member created topics. It doesn't mean that myself or any other PageLines support staff member will reply with a correct answer regarding any topic. Your questions still need to be related to PageLines products.

 

In regards to your product images not displaying this is most likely caused by either the way WooCommerce is configured, how you have setup your products or a plugin is causing an issues. As I have just this moment created a product, added a feature image and the image displays just fine.

 

https://cloudup.com/caLFHv1vVbD

 

In regards to the filter not working on mobile, you do not drag it on mobile devices, you click where you want it to be. This isn't an issue with DMS, but how the widget functions. As for the cut off, it does appear that the widget styling in DMS and other themes I tested is effecting the WooFilter widget. To resolve this add the following CSS:

 

#site .widget_price_filter {
overflow: visible;
}
 
 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

@Danny 

 

I asked the questions below and you didn't answer.... Please answer.  

 

How is the sidebar being implemented in your demos?  Which custom sidebar tool is being used and what size are the product photos loaded into Woo?  I'm using the free version of Custom Sidebars.  If you don't know how they were implemented in the demos, how did you implement?

 

Also, I think it is something todo with Woo and DMS together.  If you look at https://www.hibbslupustrust dot org another DMS site (not a site I did) and add a product to the cart, the same issue I have also appears on that site...I found others in the "Share your DMS2 site" thread.  If we are all doing it wrong Pagelines should get documentation out so we can do it right.  Otherwise, I would say that DMS has and issue with Woo.  The related product images are all largely sized and pixelated as well but that's covered in another post.   I've implemented Woo in a number of other sites using different Frameworks or themes and these types of issues don't exist.  Why is it so difficult with Pagelines to get documentation and answers?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Okay.  I tested through the plugins and it is DMS Pro Tools 1.6.2 with Lazy Load Images checked that causes the issue.  If Lazy Load is left unchecked the image shows fine.  It would be nice to be able to use Lazy Load and still have the cart images show:)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

jmad im on it.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Nice.  And great response time.  

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now