Jump to content


Photo
- - - - -

"Forced To Row" -- too much space between lines


Best Answer Danny , 10 July 2014 - 12:16 PM

I've logged into your site and added some custom CSS which remove the white space from some of the sections, thus reduces the gap between the sections. This is simple CSS, in future you will need to do this yourself, which you can do by using your browsers dev tools.

 

If you view your custom CSS you find the following:

 

/* Danny's custom css
 * which removes the white
 * space from the header sections
 * DO NOT REMOVE
*/
 
#quickslideru39nfwi .flex-gallery {
  margin-bottom: 0;
}
 
#simple_navuxr7drv .pl-section-pad {
  padding-top: 0;
  padding-bottom: 0;
}
 
Do not remove it unless you're not happy with the results.
Go to the full post


  • Please log in to reply
28 replies to this topic

#1 thesongchanneler

thesongchanneler

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • Framework Version:Free
  • Country: Country Flag

Posted 21 June 2014 - 06:01 PM

 

Hi Danny~~ I'm sorry for adding multiple questions in one post, earlier. I created this new one just for this question. 

 

You said I somehow was using the "forced to row" option under my media box (logo) and slider, and that if I change this, it should reduce the space between these and the nav bar below. But I can't find where to change this option for the "forced to row" or something similar... can you please tell me how to change it?

 

Thank You~

Bigislandmusictherapy.com



#2 batman

batman

    Bat Learning

  • Members

  • 2202 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 21 June 2014 - 09:39 PM

Hi @thesongchanneler

I see this

http://screencast.com/t/sd3pvqhA

I suppose that Danny write about this, you can try to see this in the Chrome editor.



#3 batman

batman

    Bat Learning

  • Members

  • 2202 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 21 June 2014 - 10:07 PM

Hi @batman

I´m not sure but, please you can try add this CSS rules

 
.pl-column-forcer {

display: none;
}


#4 thesongchanneler

thesongchanneler

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • Framework Version:Free
  • Country: Country Flag

Posted 22 June 2014 - 12:20 AM

 

Thank you, Batman....  I just did something bad, though... lol. I attempted to add the code to the "custom css" tab....  (I don't know how to add code anywhere else....   and it changed the layout of my site and won't let me click on the "custom css" tab again to erase it.....  I am also getting the error: You are only allocated 22.77MB.

Anyway at least the fix is easy. Just add the following to wp-config.php and we should be good to go.

define( 'WP_MEMORY_LIMIT', '128M' );

 

 

Do I nee to add this wp_memory code? If so... how do I access this "wp-config.php" to add it? I am a complete newbie to adding any code of any sort, and I have no idea what it is asking me to do or what I did to my site! Please help.... much appreciated...thank u



#5 thesongchanneler

thesongchanneler

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • Framework Version:Free
  • Country: Country Flag

Posted 22 June 2014 - 07:28 AM

Whatever I just did made my screen look like this:

 

http://screencast.com/t/l9glsDtK (on Chrome only, for some reason. When I open in Safari, the site looks normal, but I cannot edit out of there).

 

And this is the error message:

 

http://screencast.com/t/h36IY3U9b

 

Thank you for your help... .I can't continue to try to change the css until I get my screen mode back to normal.... what do i do?



#6 batman

batman

    Bat Learning

  • Members

  • 2202 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 22 June 2014 - 11:45 AM

Hi @thesongchanneler

First you deactivate all your plugins and see if the screen mode back to normal.

then....

Please, you take a look to this

http://docs.pageline...llocation-error

and this

http://docs.pageline...g/common-issues

I believe that you will need to contact your web host provider. Inform them of the issue and ask if it is possible for them to increase the server's memory limit.



#7 thesongchanneler

thesongchanneler

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • Framework Version:Free
  • Country: Country Flag

Posted 22 June 2014 - 07:01 PM

HI Batman.. thank you for your help: I found a way to delete the weird line of CSS in the Less/CSS area.

 

Now back to how to get rid of the "force to row" option. You said to put in: .pl-column-forcer {
 display: none; } ... I tried putting this in the 2nd line of the Less/CSS .... I also tried it with the #site tag in front, like I had to do with the code to align my slider text right: #site .flex-caption { text-align: right; } ....  but that didn't work to eliminate the forced row: .#site pl-column-forcer {
 display: none; 

 
Am I supposed to put the code somewhere else? I'm sorry..please bear with me..I am new to entering codes....and I'm not sure how you even accessed the codes for my website in order to screen capture what you screen captured. Can you please tell me how/where to access the code you want me to change? And what to put in? 
 
Or is there a different code I can put into the Less/CSS that will work, since the other one did not? Do I need a different tag besides #site?
 
Than you for your help.. much appreciated


#8 batman

batman

    Bat Learning

  • Members

  • 2202 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 22 June 2014 - 07:34 PM

Hi @thesongchanneler

I copy/paste another Bat´s reply to you 
:)

 

If you need add some CSS code you can use a Child Theme

I use for this a Danny´s Child Theme, this works fine to me in all update.

https://github.com/Dannyholt/skeleton

 

You can install the .zip like a theme in your dashboard > themes > upload

You need activate the Theme and the copy/paste yours CSS rules in the style.css

http://screencast.com/t/sZXzimY7x

 

I use the Child because I read this after update the theme

Please Note: Any customizations you have made to theme files will be lost. Please consider using child themes for modifications.

You can see the image

http://screencast.com/t/FeFQEG1Qav

 

If you need to modify a section, you can copy this to your child

For example

wp-contents > theme > YOUR CHILD THEME > sections > YOUR SECTION TO MODIFY

Please, you take a look to this

http://docs.pageline...ase-child-theme



#9 thesongchanneler

thesongchanneler

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • Framework Version:Free
  • Country: Country Flag

Posted 22 June 2014 - 08:34 PM

 

Hi Batman.... Okay, I installed Skeleton.. 

 

What I don't understand is how to access this: 

 

wp-contents > theme > YOUR CHILD THEME > sections > YOUR SECTION TO MODIFY

 

Do you mean access this thru my WORDPRESS DASHBOARD, or through files saved to my computer? On the dashboard, I can go into appearance: themes: and see that Skeleton is activated.... but not sure how to get to the "section to modify".... 

 

And if I go into my COMPUTER to the downloaded "skeleton-basic" folder, I see the sub-folders:

functions.php

readme.md
screenshot.png
style.css
style.less
 
but again not sure how to get to the "section to modify".. please, can you explain to me how to access it? THEN, finally, lol, I will have to figure out HOW to change elements successfully... lol... which is all I'm trying to do ;]
 
thank u!


#10 batman

batman

    Bat Learning

  • Members

  • 2202 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 22 June 2014 - 08:58 PM

Hi again

If you want to modify a section, never modify the core, you need to create the new directory (sections) copy the section in this and you can modify all on this.

Now you only copy the CSS rules in the style.css

Please, you take a look to this

http://docs.pageline...ase-child-theme

;)



#11 thesongchanneler

thesongchanneler

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • Framework Version:Free
  • Country: Country Flag

Posted 24 June 2014 - 02:24 AM

 

Batman, Thank u for ur help so far... Listen, this is more confusing for me than may be obvious, lol. Please bear with me and help me understand HOW to access and then modify css to make, for instance the "force to row" option disappear. I installed the child theme, and I don't understand if I'm supposed to access wp-content → themes → dms-template-theme ON MY COMPUTER -- LIKE VIA my "FINDER" on my MAC OR on my http://www.mywebsite/wp-admin. 

 

Please help me understand how to access whatever file it is that I will then alter the coding on.

 

THANK U



#12 greenfly

greenfly

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 24 June 2014 - 11:19 AM

Please help me understand how to access whatever file it is that I will then alter the coding on.

 

THANK U

 

 

The practice of child theming is not something created by PageLines. For help with Child theme usage the best place to start is in the WordPress Codex article on Child Themes here http://codex.wordpre...rg/Child_Themes

 

File's are located on your remote server (in your WordPress install) and this is where they need to be modified within your child theme using FTP. However if you are not sure about this at this point you should stop and make sure you know what you are doing before you go any further, 

 

Also if you are using the Skeleton Theme provided by Danny then the instructions to use this are on the GitHub page you downloaded the Chid theme from. Please follow his instructions there. 

 

 

Hi @thesongchanneler

I copy/paste another Bat´s reply to you 
:)

 

If you need add some CSS code you can use a Child Theme

I use for this a Danny´s Child Theme, this works fine to me in all update.

https://github.com/Dannyholt/skeleton

 

You can install the .zip like a theme in your dashboard > themes > upload

You need activate the Theme and the copy/paste yours CSS rules in the style.css

http://screencast.com/t/sZXzimY7x

 

I use the Child because I read this after update the theme

Please Note: Any customizations you have made to theme files will be lost. Please consider using child themes for modifications.

You can see the image

http://screencast.com/t/FeFQEG1Qav

 

If you need to modify a section, you can copy this to your child

For example

wp-contents > theme > YOUR CHILD THEME > sections > YOUR SECTION TO MODIFY

Please, you take a look to this

http://docs.pageline...ase-child-theme

 

This information From Batman is very useful. 

 

Also 

 

I am new to entering codes....and I'm not sure how you even accessed the codes for my website in order to screen capture what you screen captured. Can you please tell me how/where to access the code you want me to change? And what to put in? 

 

CSS is easy to work with but you need to read about the basics first:

 

Start here http://docs.pageline...ide-default-css

 

for this :- 

 

I also tried it with the #site tag in front, like I had to do with the code to align my slider text right: #site .flex-caption { text-align: right; } ....  but that didn't work to eliminate the forced row: .#site pl-column-forcer {
 display: none; 

 

 

you cannot work with ID selectors and class selectors in this way 

 
.#site pl-column-forcer {
 display: none; } 

You can see the difference by reading here http://www.w3schools...s_selectors.asp

 

 

It looks like the reason this topic has gotten a little confused is it is not clear to which topic this topic refers. Danny Original suggestion regarding 'force to new row' is a feature located in your visual editor 

 

here http://screencast.com/t/Za0zB4OLktzd



#13 thesongchanneler

thesongchanneler

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • Framework Version:Free
  • Country: Country Flag

Posted 25 June 2014 - 06:22 AM

 

Hey Martin and Batman... again, thank u for ur help. I did some research on CSS and child themes, but I will do more before asking more questions. I really appreciate your help, and don't want to unnecessarily burden you.

 

Re: the "force to row," Martin just posted: 

 

It looks like the reason this topic has gotten a little confused is it is not clear to which topic this topic refers. Danny Original suggestion regarding 'force to new row' is a feature located in your visual editor 

 

here http://screencast.com/t/Za0zB4OLktzd

 

But I don't see that option on my visual editor... I see the option to "increase width" and "offset amount" (and "offset amount" is set to "0" and creates a little cross as the cursor, without an option to change it) and that's it. I can't figure out how to take a screen shot of it because the editing details goes away when I move my cursor. Knowing this, is there any other info you can give me about fixing the "force to row" without having to access my new child theme css? Is there something I can just type into "less css" for now, or a way to make the option in the visual editor appear? 

 

Thank You....



#14 thesongchanneler

thesongchanneler

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • Framework Version:Free
  • Country: Country Flag

Posted 05 July 2014 - 06:12 PM

 

Hello,

 

I'm still trying to fix the "force to row" situation on my site. I've since switched domains, and am now songcreationarts.com. I just re-did most of what i Had before, and the same situation with too much space between header and nav bar exists. I've installed a child theme. Can you please tell me what code to insert to correct the "force to row"? 

 

THANK YOU



#15 Danny

Danny

    Is Awesome!

  • Moderators
  • 17580 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 07 July 2014 - 12:27 PM

I am not sure what you're using the Force to new row ? There is no need ?

 

By using it all you're doing is adding an extra gap, which serves no purpose as far as I can tell.



#16 thesongchanneler

thesongchanneler

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • Framework Version:Free
  • Country: Country Flag

Posted 07 July 2014 - 05:16 PM

Hi @Danny ... I am trying to REMOVE the gap between logo/slider on top and nav bar below. Someone had mentioned that I was using the "force to row" option and turn it off. But it looks like it may be an issue of padding? I'm really not sure.. I would just like to remove the space between logo/slider and nav bar below, however I should do that. I just changed the logo so it is a little bigger than it will be but u can see the extra space both within the column/section and between sections.

If you can advise me, I would be very thankful!

#17 Danny

Danny

    Is Awesome!

  • Moderators
  • 17580 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 08 July 2014 - 07:44 AM

You still appear to be using the Force to new row, the code is present on your site, please remove it and this should resolve your issue. The Force to new row appears to be connected to the right hand column which houses the QuickSlider.



#18 thesongchanneler

thesongchanneler

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • Framework Version:Free
  • Country: Country Flag

Posted 08 July 2014 - 07:51 AM

Hi @Danny.. Can you please explain to me how to change the code for force to row? How do I access where the code is presently and what do i change exactly?

This was the question that was never answered.... I don't know HOW/WHERE to change the code.

Please guide me.. Hopefully after this I will be more familiar with how to change the codes. Thank u

#19 Danny

Danny

    Is Awesome!

  • Moderators
  • 17580 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 08 July 2014 - 09:59 AM

There is no code required, you have clicked on the Force to new Row button. Therefore, if you want to remove it, you're going to need to remove that section/column and add it again. Forcing to new row, can not be reverted once it has been done.



#20 thesongchanneler

thesongchanneler

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • Framework Version:Free
  • Country: Country Flag

Posted 08 July 2014 - 05:23 PM

Hm... This is my second domain that I'm building with DMS and I have removed and added that section several times before... It automatically looks this way. I will try again, but I cannot see why it is doing that.. It just does it. Let me see if anything changes...