• 0

Getting main search navi bar to search Woo Commerce products

Question

Posted · Report post

Is there some way to get the main search in the nav bar to search woo commerce products? Currently it doesn't turn up Woo products in the results. Thanks

Share this post


Link to post
Share on other sites

7 answers to this question

  • 0

Posted · Report post

You need to add the postloop section to a search results page.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,

 

I am able to recreate this issue. I have just this moment added a new product called "Playstation", I then go to the Navi search bar and type in Playstation and the search results display this product.

 

If this isn't working for you then you likely have some configuration on WordPress or WooCommerce that is preventing your products from being indexed.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks Danny. I see what's going on now. I installed PinsPro a while back and tried to copy over the plugins (and maybe the templates?) and then switched back to DMS, but the PinsPro templates are still showing up as templates and the content loop isn't there so nothing showed up.

 

Is there supposed to be an 'archive' template in DMS? Here is what I'm seeing in my templates. Am I missing some things there?

 

http://imgur.com/6sI2ICJ

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yep, I got that already.  Just wondering about the templates now and why the PinsPro stuff is there. Is there a list of all the default DMS templates somewhere so I can confirm I've got everything I should?

Thanks.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You have all the DMS default ones there + the pinspro ones, nothing out of sorts.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks for informing us the issue has been resolved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now