Jump to content


Photo

Posts Page Template unavailable in Page Attributes


Best Answer VFE1 , 17 June 2014 - 05:54 PM

I've resolved this issue via PlugIns. Thank you!

Go to the full post


  • Please log in to reply
10 replies to this topic

#1 VFE1

VFE1

    Newbie

  • Members
  • Pip
  • 6 posts
  • Country: Country Flag

Posted 13 June 2014 - 08:09 PM

Hello, I've done quite a bit of searching and I seem to be having the same issue as this gentleman:http://forum.pagelin...-post-template/

 

I've already selected the Sections I want to use for Posts Pages via the Template Setup in PlatformPro Settings, but when I am in "Edit Page"---> Page Attributes--->Template, the Posts Pages template is unavailable in the dropdown menu.

Thank you, VFE1



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 June 2014 - 11:27 AM

Hi,

 

Can you provide a screenshot of the drop down menu for your templates please. So we can see what templates you actually have.



#3 VFE1

VFE1

    Newbie

  • Members
  • Pip
  • 6 posts
  • Country: Country Flag

Posted 16 June 2014 - 06:29 PM

Here is the drop down menu encircled below:

3f97254d-b560-449a-bb9a-cedcd872e6bc_zps


Edited by VFE1, 16 June 2014 - 06:30 PM.


#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 17 June 2014 - 10:16 AM

You can not edit the the Posts page like that, because as soon as you use static pages via the Reading options in the WordPress Admin Dashboard, that Post page is considered a special page/dynamic page. To configure that page, you need to use the Platform Pro template settings, as far as I can remember it is called Posts Page.



#5 VFE1

VFE1

    Newbie

  • Members
  • Pip
  • 6 posts
  • Country: Country Flag

Posted 17 June 2014 - 04:32 PM

^Thank you. We're still in the same dilemma as this thread: http://forum.pagelin...-post-template/

 

The Platform Pro template settings you are referring to only configure the settings for the type "Posts Page". I guess another way to say it is that "Pages" display on the site, but "Posts pages" do not display live when published as the "Pages" do.

 

IE- This post (Posts page) below is published but not visible through any links/navigation settings:

Postspageie_zpsf56927c1.jpg

 

I think we're slowly getting close to unravelling my noobness factor causing the issue :)


Edited by VFE1, 17 June 2014 - 04:33 PM.


#6 VFE1

VFE1

    Newbie

  • Members
  • Pip
  • 6 posts
  • Country: Country Flag

Posted 17 June 2014 - 05:54 PM   Best Answer

I've resolved this issue via PlugIns. Thank you!



#7 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 18 June 2014 - 09:30 AM

Not sure what your post with the images is supposed to display ?

 

Pages and Posts are two different things, if you publish a post, it will display on your Posts Page and Pages when published will display as a page.

 

Also, not sure what you mean when you say this:

 

"IE- This post (Posts page) below is published but not visible through any links/navigation settings:"

 

All posts that are published, can be viewed by going to either your blog or using the link for that post. I am not sure what you have resolved via plugins?



#8 VFE1

VFE1

    Newbie

  • Members
  • Pip
  • 6 posts
  • Country: Country Flag

Posted 18 June 2014 - 04:50 PM

I'm not 100% sure, but I think what was causing the Posts pages not to show was something to do with plugins installed by the previous developer. Posts pages do not show up even when published. Using a different plugin allowed even more customization of the Posts, and more importantly, the posts displayed as a Page rather than the typical Posts page. Hope that makes sense...

 

The plugin we're now using is Special Recent Posts: http://www.specialrecentposts.com/

This is saved for now as .../blog-2/ for live content while making final tweaks.

http://vf-engineering.com/blog-2/


Edited by VFE1, 18 June 2014 - 04:53 PM.


#9 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 19 June 2014 - 08:59 AM

OK, your issue is that from the looks of it, you haven't setup static pages. That is why when you go to:

 

http://vf-engineering.com/blog/

 

it just displays a page and not your blog of posts. To resolve this, you need to go to WordPress Admin Dashboard > Settings > Reading, then in the options for Front page displays, select a Page for your Homepage (Front-page) and then select in the drop down menu, your Blog page for Posts Page and save the changes.

 

When you go to your blog now

 

http://vf-engineering.com/blog/

 

It should display your posts, using the PageLines loop section.

 

What you have done is created a page called Blog2 and then used the Special Recent Posts plugin to create a separate blog. However, there is no need to do this, as WordPress does this already, as long as you follow my instructions above.


  • VFE1 likes this

#10 VFE1

VFE1

    Newbie

  • Members
  • Pip
  • 6 posts
  • Country: Country Flag

Posted 19 June 2014 - 06:11 PM

Thanks, Danny! That's the trick. We now have more options of how we can set our Posts.



#11 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 20 June 2014 - 08:47 AM

Awesome and no problem. Thanks for informing us this resolved your issue.