Jump to content


Photo
- - - - -

Error messages ; postpins and register_metatab

postpins

  • Please log in to reply
7 replies to this topic

#1 jane

jane

    Advocate

  • Members
  • 347 posts
  • Country: Country Flag

Posted 13 June 2014 - 07:01 PM

Hello,

 

I enabled wp_debug and got these error messages; what, if anything, should I do?

 

Notice: Undefined property: PostPins::$icon in .../wp-content/plugins/postpins/postpins.php on line 318

Notice: register_metatab is deprecated since version 1.2 of PageLines DMS! Use section_opts() instead. in ...wp-content/themes/dms/dms/includes/deprecated.php on line 272



#2 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 13 June 2014 - 07:07 PM

They are just notices, why did you enable debug?

#3 dreja

dreja

    Newbie

  • Members

  • 7 posts
  • Country: Country Flag

Posted 13 June 2014 - 07:10 PM

 edit



#4 jane

jane

    Advocate

  • Members
  • 347 posts
  • Country: Country Flag

Posted 13 June 2014 - 07:12 PM

My host provider is trying to help me figure why I've been having so many issues so they suggested enabling debug. In doing so, the DMS editor no longer worked and those notices appeared. So now it's been disabled. 

 

I take it from your response that notices are not that important?



#5 Danny

Danny

    Is Awesome!

  • Moderators
  • 15907 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 June 2014 - 11:21 AM

Notices can be ignored, they're just notices such as the one you mentioned in your post which informs you that something is using a deprecated function.

 

However, if you enable WP_DEBUG and the DMS visual editor isn't working, then there is something seriously wrong with your site, as the DMS editor/toolbar should still function with WP_DEBUG set to true.



#6 jane

jane

    Advocate

  • Members
  • 347 posts
  • Country: Country Flag

Posted 15 June 2014 - 11:42 AM

Is there someone that would be able to look into this issue for me right away? I am willing to pay.



#7 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 15 June 2014 - 12:45 PM

Turn off wp debug
Why your host thinks enabling it on a site that already functioning is beyond me


Sent from my iPad using Tapatalk

#8 jane

jane

    Advocate

  • Members
  • 347 posts
  • Country: Country Flag

Posted 15 June 2014 - 01:14 PM

I did. Ultimately, it looks like something is wrong though...maybe it's down to a plugin?







Also tagged with one or more of these keywords: postpins