Jump to content


Photo

PageLines PHP Memory Limit error


  • Please log in to reply
5 replies to this topic

#1 surefoot

surefoot

    Newbie

  • Members
  • Pip
  • 4 posts
  • Framework Version:1.1.1
  • Country: Country Flag

Posted 13 June 2014 - 04:28 AM

Hello,

 

I have just started working with PageLines theme. It was working fine and I was happy with it till I added CSS to the Custom CSS option of the theme. It then started giving PHP memory limit error.

 

Our site already has PHP limit set as 712 MB so not sure what this actually means.

 

Please, help.

 

Thanks!



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 16358 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 13 June 2014 - 12:40 PM

Hi,

 

It is physically impossible for DMS to be using so much memory. The only way your site could run out of memory if you have it set to that much, is if you have about 1000 plugins installed, which I bet isn't the case.

Therefore, it is most likely that you do not have that much memory. Some hosts say they give X memory, but then install a script that actually gives you much lower value. Would it be possible for you to provide a link to the site in question and enable DMS Debug mode ~ DMS Toolbar > Site Settings > Advanced. So we can take a closer look.



#3 surefoot

surefoot

    Newbie

  • Members
  • Pip
  • 4 posts
  • Framework Version:1.1.1
  • Country: Country Flag

Posted 13 June 2014 - 05:39 PM

Hello,

 

Thanks the issue got resolved when I found I could delete the css from wp-admin. But why did it give memory error when the issue was with css?



#4 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 13 June 2014 - 05:47 PM

what was the error produced?

#5 surefoot

surefoot

    Newbie

  • Members
  • Pip
  • 4 posts
  • Framework Version:1.1.1
  • Country: Country Flag

Posted 16 June 2014 - 05:13 AM

Hello,

 

The error was as below:

 

Looks like your hosting providers have limited the amount of memory you can use for PHP

You are only allocated 31.92MB.

Anyway at least the fix is easy. Just add the following to wp-config.php and we should be good to go.
define( 'WP_MEMORY_LIMIT', '128M' );



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 16358 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 16 June 2014 - 09:14 AM

I would still contact your web host provider and ask them to increase your memory.