• 0

DMS 2 Change Language


Question

Posted · Report post

Hi,

How can i change the language of this specific Mansonic Gallery ("All", "Sort"). I already changed the language file. Everything seems translated except the Mansonic Gallery. At least that I have noticed.

 

Captura_de_ecr_2014_06_5_s_17_54_20.png

 

Share this post


Link to post
Share on other sites

28 answers to this question

  • 0

Posted · Report post

HI,

 

Can you provide the exact steps you took in order to translate please.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Danny,

I follow the steps in this article and use the Portuguese (Brazil) pack here.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Are you using a child theme or a customize plugin ?

 

You should probably use a child theme like the one I created here - http://dannyholt.github.io/skeleton

 

Also have changed the files in your wp-conflg.php file like the docs state ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

No, I'm not using a child theme. I've just instal DMS 2 and star personalizing the home page, in witch i add the Mansonic Gallery.

I do everything that the docs state and everything was translated except the Mansonic Gallery and i noticed now that when I use the search box, the "Posted" and "READ MORE" wasn't translated also.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

How can you follow the instructions on our documentation, but not use a child theme ? If you do not use a child theme, then you have likely added your language files to the core DMS language folder. When an update to DMS is released, your files will be deleted by the update.

That is why you need to use a child theme, you can use the one I created here - http://dannyholt.github.io/skeleton

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Sorry, I use a child theme. It's in wp-conten/themes/dms/dms/languages.

I already have open the file with Poedit and looked for those strings (All, Sort, Posted, Read More...) but i couldn't find them there.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You can't be using a child theme in the directory you mentioned, please use a child theme correctly. Simply download the one I created here and install it like any other WordPress theme. Then via your FTP client, add a language folder and add your .po and .mo files there.

 

http://dannyholt.github.io/skeleton

 

Once you have done this, reply here and we can take it from there.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok, I've installed the child theme and created the language folder with .po and .mo files. (I didn't activate the child theme)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You need to activate the child theme, then see if the section has been translated, if it hasn't reply here and we can take a closer look.

 

Also perform a backup before activating the child theme just as a precaution.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

It isn't translated, it's everything in english. I put the language folder under wp-content/themes/skeleton-advanced/

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

So your website is now in English, not Port-Brazilian ? If that is the case, then you there is something definitely wrong. It should at least be in the language you have selected.

 

Can you list the exact steps you have taken please.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I do as I said in de previous posts. Everything was translated except those strings that I refer (All, Sort, Posted, Read More...).  

The only diference is that now I've put the language folder that was in the wp-conten/themes/dms/dms/languages directory, inside the wp-content/themes/skeleton-advanced/ folder.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok, you're confusing me now. Before you were using the child theme and added the .po and .mo files to the DMS language folder (which isn't correct), your site was in Porto-Brazilian, except for the Masonic section.

But then you followed my instructions and use a child theme and enabled it, then you said the following:

 

It isn't translated, it's everything in english. I put the language folder under wp-content/themes/skeleton-advanced/

 

So is your website in English after using a child theme or is it in Port-Brazilian except for the Masonic section ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

My site is in English after using the child theme, it doesn't apply the language PT_br at all.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Can you provide a screenshot of your wp-config.php file so I can see how you have set the LANG

 

Also, can you provide a screenshot of your child theme folder and another screenshot of your language folder inside your child theme. You can do this by using an FTP client and taking the screenshots of the app.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

[url=http://postimg.org/image/mfrei9ot3/]Captura_de_ecr_2014_06_11_s_12_43_00.jpg[/url]

[url=http://postimg.org/image/p8u2wpisx/]Captura_de_ecr_2014_06_11_s_12_43_36.jpg[/url]

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

OK your first screenshot of your wp-config.php file doesn't show me what you have set the LANG too, can you take another screenshot so I can see what this is.

 

Also, in your second screenshot, I am not see any pt_BR.po or pt_BR.mo files ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

[url=http://postimg.org/image/6nkiurjhv/]Captura_de_ecr_2014_06_11_s_13_00_23.jpg[/url]

 

The files inside the second screenshot named (pt_PT) are the (pt_BR). I just renamed the files to match the WLANG I set in the wp-config file. (pt and br are similar languages)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Why have you set the LANG to that if you want Portuguese (Brazil) you need to set it to this:

 

pt_BR

 

Your .po and .mo files need to be named the same too. All this information is on the WordPress codex and on this page here - http://wpcentral.io/internationalization/

 

I recommend you read the WordPress codex documentation for assistance in translating your website.

 

http://codex.wordpress.org/WordPress_in_Your_Language

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I do as you said and everything is translated except the DMS.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

So you now have the correct named .po and .mo files in your language folder via your child theme and also have set the correct LANG in your wp-config.php file ?

 

Also what do you mean by everything is translated except DMS, are you suggesting that all the WordPress backend etc.. is translated to Portuguese (Brazilian) but nothing in DMS ?

 

If so, please contact our helpdesk and provide the following information:

 

A link to this topic so our staff have something to reference

A link to the site in question

Your admin username/password

Your FTP details so we can view the files personally

Make sure all plugins are disabled

Make sure DMS debug mode is active

 

hello at pagelines dot com 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks, i already send the email.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hello,

I have send the email and it was told me by email that the information provided was added to the forum ticket and is visible to the forum moderators.

However nobody contacted me and the problem isn't solved.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Is anyone there?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi there,

 

having the same issue with a blog.

http://raidbait.de/blog/category/bodensee/

Everything is German, but not "read more", "posted", "comments"...

 

In the de_DE pageline language files even those buttons are translated. But they are not shown in German.

 

I do not use a child theme. What do I need it for? Why?

 

I also found this:

http://forum.pagelines.com/topic/20833-change-english-text-change-comment-form/

As this is from 2012 it is not relevant for DMS2 I guess...

Because I do not have the mentioned menu "Wordpress Admin Dashboard > PageLines > Site Options > Blog & Posts > Continue Reading Link Text".

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now