Jump to content


Photo

Background image fixed-width


This topic has been archived. This means that you cannot reply to this topic.
4 replies to this topic

#1 lucbemelmans

lucbemelmans

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 12 November 2010 - 09:52 AM

Hi there,

I'm currently working on http://www.bemelmansbv.nl

I already checked other topics but couldn't find the right answer.
The problem is I can't add a background to my fixed-width site design mode.

I'm working on platformpro, file theme.css:

 body{
			height:100%;
			font-size:13px;
			line-height:1.6em;
			background-color:#f7f7f7 !important;
			color: #FFF;
			border-top:15px solid #000;
		}

I can change the colors if I want by changing the background-color (thanks to topic 3190). But if I insert the following instead of background-color it doesn't show up and I only see the standard grey background:

 background-image:url('http://bemelmansbv.nl/wp-content/uploads/2010/11/backgr.png');

I also tried a million things in the custom code CSS in the platformpro menu, but also that didn't make any changes.

Any thoughts?

#2 activeappl

activeappl

    Member

  • Members
  • 19 posts

Posted 12 November 2010 - 04:30 PM

I had the same problem, someone here helped me and it worked perfectly. In your Custom CSS, add ` body, body.fixed_width { background:url("http://bemelmansbv.nl/wp-content/uploads/2010/11/backgr.png") repeat-x fixed 0 0 #ffffff; } `

#3 lucbemelmans

lucbemelmans

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 15 November 2010 - 09:12 AM

Hi Ryan, Thanks for your reply! I tried the code in custom CSS: http://bemelmansbv.nl/screenshot.png And of course I saved my options, but still there are not any changes on www.bemelmansbv.nl I also tried both platformpro as platformbase. I'm desperate, can somebody help me with this please?

#4 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 15 November 2010 - 07:44 PM

I do some change using the !important tag. and you could do the same here with your background image body.fixed_width { background:url("http://bemelmansbv.nl/wp-content/uploads/2010/11/backgr.png") repeat fixed 0 0 #FFFFFF !important } Also, you'll have less trouble if you update the theme.

#5 lucbemelmans

lucbemelmans

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 16 November 2010 - 09:56 AM

Thanks Adam, That did the trick. I inserted the code in the custom code panel.