Jump to content


Photo
Grid Shortcodes

Third column jumping onto next line - [span8][span2][span2]



  • Please log in to reply
4 replies to this topic

#1 caspersjan

caspersjan

    Super Member

  • Members

  • 188 posts
  • Country: Country Flag

Posted 22 May 2014 - 07:44 PM

Dear Pagelines, dear Evan,

 

Grid Shortcodes is doing its simple work solidly, it probably never gets much praise. I am glad that it has been continued through all of Pagelines iterations since it arrived on the scene!

 

However now I have a problem I fail to understand. I thought the spans can add up to 12. I am trying to achieve a three column set-up, like this:

 

[row]
[span8]Text[/span8]
[span2]Text[/span2]
[span2]Text[/span2]
[/row]
 
But it breaks, i.e. the third column is put on a new page. If I try this it doesn't work either:
 
[row]
[span3]Text[/span3]
[span3]Text[/span3]
[span3]Text[/span3]
[/row]
 
Am I doing something wrong or leaving something out? You can see the page here: http://animatinglibr...ordpress/?p=247 (underneath the second <hr> divider, "Report"/"Group size"/"Sessions")
For a practical fix I used this solution - just making the wide column narrower:
 
[row]
[span7]Text[/span7]
[span2]Text[/span2]
[span2]Text[/span2]
[/row]
 
But I'd like to use the whole line - without the margin at the front and end that the 7/2/2 solution entails. Maybe you can help - I am as ever grateful for your assistance.
 
Yours faithfully, Jan.
 
 
 

 



#2 Evan Mattson

Evan Mattson

    Super Member

  • Members

  • 233 posts
  • LocationAnn Arbor, MI
  • Framework Version:latest stable & beta releases
  • Country: Country Flag

Posted 22 May 2014 - 08:00 PM

Hey @caspersjan,

 

It seems like maybe you're trying to nest the grid shortcodes?  Do you have more than one level of shortcode hierarchy there?



#3 caspersjan

caspersjan

    Super Member

  • Members

  • 188 posts
  • Country: Country Flag

Posted 22 May 2014 - 08:12 PM

Dear Evan, an out-of-this-world response time! No, I'm not trying to nest the grid shortcodes, at least as far as I am aware. Below is my entire post. I underlined the offending row. There is a two-column row ([row][span2]stuff[/span2][span10]stuff[/span2][row]) that works perfectly. Again, you can see it on the page: http://animatinglibr...ordpress/?p=257 (this time broken, with [row][span8]stuff[/span8][span2]stuff[/span2][span2]stuff[/span2][row] as intended). Does this mean anything to you? I am lost! Thank you for looking into it, it's much appreciated! Greetings, Jan.

 

<table width="100%"> 
<tr> 
<td align="left"><h4>Animating Libraries Activity Archive</h4> </td> 
<td align="right"><h4>(#022) </h4></td> 
</tr> 
</table>
<hr>
[row]
[span2]
<img class="img-circle" <img src="http://animatinglibr...all-150x150.png" />
[/span2]
[span10]
Date: 22/05/2014
<h4 class="workshoptitle">Grid Test</h4>
Librarian: 
Location: 
Group:
 
[/span10]
[row]
<hr>
[row]
[span8]
<u>Report</u>
 
[/span8]
[span2]
<u>Group size</u>
 
<u>Age</u>
 
<u>Gender</u>
 
[/span2]
[span2]
<u>Sessions</u>
 
<u>Type</u>
 
<u>Level</u>
 
[/span2]
[/row]
<hr>
Videos
<hr>
Photos
<hr>
Photo archive


#4 Evan Mattson

Evan Mattson

    Super Member

  • Members

  • 233 posts
  • LocationAnn Arbor, MI
  • Framework Version:latest stable & beta releases
  • Country: Country Flag

Posted 22 May 2014 - 11:55 PM

@caspersjan,

 

It looks like you have an opening [row] right after your closing [/span10] instead of a closing [/row].  That will mess things up for you! ;)

 

Try fixing that and let me know if you're still having trouble.

 

Cheers!



#5 caspersjan

caspersjan

    Super Member

  • Members

  • 188 posts
  • Country: Country Flag

Posted 23 May 2014 - 12:40 AM

Dear Evan, indeed you are right and all is right now! Thank you so much - I shall remember this and will know what to look for should something like this ever come up again. And thank you for keeping Grid Shortcodes going! Good luck, yours faithfully, Jan.







Also tagged with one or more of these keywords: Grid Shortcodes