Jump to content


Photo
- - - - -

script to add a FB Like box


  • Please log in to reply
5 replies to this topic

#1 springmoon

springmoon

    Member

  • Members
  • PipPip
  • 18 posts
  • Country: Country Flag

Posted 18 May 2014 - 06:39 PM

I am trying to add a Facebook "Like Box" in a widget on my site. Per Facebook, they ask you to include a snipet of coding on your site in order for their plugin to work. They state, "Include the JavaScript SDK on your page once, ideally right after the opening <body> tag."

 

So I added this script in the Custom Scripts in DMS. I do not have anything else written in that box at this time.

 

I then added their code for the plugin in a text box in a widget. The Like Box does not appear on my site, I just get a big blank space.

 

Any thoughts on what needs to happen in order for me to be able to add this content on my site?



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17131 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 19 May 2014 - 10:04 AM

HI,

 

Facebook actually have a official WordPress plugin which offers a lot of functionality including a Like Box widget. I would recommend installing this plugin and just add the widget to your sidebar - https://wordpress.or...ugins/facebook/



#3 springmoon

springmoon

    Member

  • Members
  • PipPip
  • 18 posts
  • Country: Country Flag

Posted 19 May 2014 - 04:24 PM

thank you! i had already installed the facebook plugin but had not noticed the widgets!! :startle:

 

i added the widget, but it still isn't displaying on my site...


Edited by springmoon, 19 May 2014 - 04:24 PM.


#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 17131 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 20 May 2014 - 09:22 AM

It's working for me without any problem, you will need to make sure you have the plugin configured correctly.

 

https://cloudup.com/cIbhenwJ1YE



#5 springmoon

springmoon

    Member

  • Members
  • PipPip
  • 18 posts
  • Country: Country Flag

Posted 20 May 2014 - 01:05 PM

hm yeah there must be a setting that isn't set right, but i have no idea what that could be. i am looking at every possible thing.

 

if i look at the debugger, in the facebook plugin, it doesn't show any of the facebook widgets as "active" even though i have added one to my website (and it isn't displaying). the plugin seems to be properly connected to the app.

 

any ideas at all?



#6 greenfly

greenfly

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 20 May 2014 - 09:47 PM

Hello @springmoon

 

First try disabling all other non-pagelines plugins to see if this allows the Facebook plugin to work correctly. If you find the plugin works correctly then re-enable the plugins one by one to see which is causing the conflict. 

 

Any further issues and if you require support for the plugin itself you can get this on the WordPress plugin support page here http://wordpress.org...plugin/facebook