• 0
Sign in to follow this  
Followers 0

To fix no thumbnail in Facebook, delete thumbs in White House?


Question

Posted · Report post

Hello, I wrote a couple of times before, and you were very helpful, thank you.

 

I'm still using your White House. I have never been able to share links on Facebook and have the thumbnail show, which really limits my sharing, and makes me very sad, since I'm a cartoonist and I really need images/thumbnails to show.

 

For many months I have been disallowing Google  to scrape my images, but recently I did allow Facebook. Yet the thumbnails still didn't appear. I have been trying 10 or 12 plugins for days, trying to get them to show, and testing in the debugger.

 

Now I realize that the debugger can see my icons, and see the thumbnail on my post page, and tells me it's too small, of course. I think I used css to block the WH thumb on my blog, because my full size cartoon is right there, and it doesn't make sense to have a thumbnail right on top of my fullsize image. So even though the thumb does not show on my post, the debugger can see it, and thinks that's the size I want to share.

 

I would like to stop the thumbs from appearing anywhere on my site, and I think this would also allow Facebook to see my REAL image. Do you have any suggestions on how to block the thumbs in the editor? I see them listed many times in features.php, and I don't want to delete the wrong ones!

 

Thank you with hope.

 

 

Share this post


Link to post
Share on other sites

3 answers to this question

  • 0

Posted · Report post

HI,

 

WhiteHouse Pro is no longer supported, as it is a legacy theme and has been for nearly two years. If I was you then I would upgrade to DMS as soon as possible.

 

However, if you install Yoast SEO, it includes options that will include OG:Data which should resolve your issue, so you may want to try that.

 

Although, personally, you really should upgrade to DMS.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Am I in the wrong forum? Sorry. I have plain White House, not Pro. Free. I thought this forum section was for free themes.

 

I doubt that Yoast will resolve anything, as I've already tried 10 other fixes. The problem, which I just realized last night, is the "thumbs" in the theme. I've never had them in a theme, and forgot they were there. I was just asking how to remove them in code, so Facebook will stop seeing them!

 

http://donnabarstow.com/

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Donna, no you're in the right forum, what Danny was saying is that Whitehouse is now a legacy theme, so is no longer updated or supported. As the theme is so old going forwards you will notice problems begin to occur as WordPress updates it core code.

 

I would suggest using the facebook delinter - https://developers.facebook.com/blog/post/2010/06/11/debugging-urls-with-the-facebook-url-linter/ which allows you to go through and check which content is being pulled from page into facebook.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0