• 0
Sign in to follow this  
Followers 0

DMS 1 Facebook won't show excerpt nor Featured Image


Question

19 answers to this question

  • 0

Posted · Report post

You don't have any Open Graph meta tags set up for your page. Although you don't HAVE to have them, it's helpful for letting Facebook to know what information you want to pass on to the news feed when you share a link.

 

If no Open Graph tags are found, Facebook will do its best to figure out what to show on the news feed. For example, it will usually try to search for the best picture on that page to use, but if that page has the image meta tag loaded in the page's <head>:

 

<meta property='og:image' content='IMAGE URL' />

 

It will use that image every time. 

 

Anyway, that's beside the point, just trying to give you a little education on how Facebook works. For your issue, Facebook probably crawled your page before you added an image. Facebook uses a caching system that resets every 24 hours or so, so the image you added wouldn't show up until Facebook's cache reset. So even though you added an image after the fact, it wouldn't show up on the Facebook news feed because that page was already cached and as far as Facebook was concerned, there was no image to display.

 

The good news is that you don't have to wait 24 hours for the cache to reset. You can reset it immediately by going to https://developers.facebook.com/tools/debug/ and entering your URL there. Facebook will reset the cache for that page right there on the spot. Now it's also going to give you all sorts of warnings about that page because there are no OG Meta Tags detected, but that's ok. Like I said Facebook will do what it can to show the best content. 

 

Anyway, I confirmed your issue by sharing your link on a Facebook news feed, and yes, the image didn't show up. Then I went to the debugging tool, entered the URL, which reset Facebook's cache for that page, and now the image shows up correctly. This would have probably happened sometime today anyway when the cache automatically resets, but now you know how to do it instantly. 

 

Anyway I recommend getting a plugin that will generate OG meta tags for all of your pages. My plugin, Facebook All-in-One DMS (that is a DMS section) will allow you to do this, but there are probably others out there too. Here's some more information about Open Graph meta tags that I wrote: http://facebook-all-in-one-dms.mrfent.com/open-graph-meta-tags/

2 people like this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,

 

What are you using to try and share your post, as far as I know the sharebar included in DMS only shares the link, if you want to share a post, don't use need to use a plugin ?

 

I have no idea on this subject matter as I don't and have never used Facebook.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I simply copy and paste the url of the post on Facebook status. Facebook is supposed to fetch the post title, featured image and post excerpt. It doesn for all sites, but it isn't doing for my site mentioned above.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Do you have a link to the article on facebook where it mentions this functionality ? 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Sorry Danny, but if you are not familiar with Facebook you don't understand what I'm talking about. Isn't there any other staff member who would know about it?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

All our other staff members use Facebook, but they do not work on weekends. I will leave a note to your topic so that they can respond.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thank you very much for your help!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

OK, so I have just this moment added a blog post from PageLines.com onto a newly created facebook account and the post title, featured image and excerpt all seem to appear without any issue.

 

https://cloudup.com/cpM8FStBx0m

 

Therefore, do you have Yoast SEO installed with the og:data active ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Exactly! That it is what it should happen. And it actually always happened with my site. But it stopped working... Dunno why. Try posting the link on my first post above for you to see what happens.

 

 

And no, I dont have Yoast SEO. Should I install it, then?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

If you have a WordPress powered website, Yoast SEO is one of those plugins that you should install as soon as possible, as it's pretty much the best SEO plugin for WordPress.

 

However, if this was working and has suddenly stopped, that sounds like a plugin may be causing an issue in my opinion.

 

So disable all active plugins and see if this resolves your problem, if it doesn't then install Yoast SEO, configure it and then try again.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

That's the thing. I have tested disabling all the plugins and nothing... I'll install Yoast later today and let you know.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

OK, thanks. My shift is about to end, but i'll keep checking your post to see if Yoast resolves the issue. I will also speak to our developers or other staff that use Facebook on a regular basis and see if I am misguiding you lol.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thank you, Danny!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks Chris for your input, I am a bit of a social newbie!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks! That was very helpful! :D

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Is the issue now resolved ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yes because MrFent used Facebook debugger. I will have to test now with Yoast SEO, but then I'll need to write another post to test it.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

OK, I will mark the topic as resolved for the time being.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi, 

 

     I have face a similar issue with my website. I am using DMS2, in Facebook debug page it shows that I have errors for :

 

Extraneous Property      Objects of this type do not allow properties named 'pl-share-url'.

Extraneous Property      Objects of this type do not allow properties named 'pl-share-desc'.

Extraneous Property      Objects of this type do not allow properties named 'pl-share-img'. 

Extraneous Property      Objects of this type do not allow properties named 'pl-share-title'.

 

The type which Facebook recognize is website type.

 

are these meta files are the default metas for DMS2 ?

 

If you see the Facebook page of my website you will realize that it dose not show the descriptions. any idea PLZ ?????? 

 

https://www.facebook.com/geoinformation.online

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0