Jump to content


Photo
PageLess

Problem with Page{Less} and full-width Navi section in DMS2

css navi logo navi full dms2

Best Answer Evan Mattson , 21 April 2014 - 02:14 AM

@layasamadhi,

 

Hello again!  After doing some digging, I was unable to figure out exactly why things were breaking the way they were.  I don't really think my extension is to blame because my method of saving (which seems to be the culprit here) has not changed from older versions of DMS which had no problem before.  However, I believe I have resolved the issue now and I have just released an update (1.2.4) that should take care of it.

 

Please let me know if you continue to have any problems after the update.

Go to the full post


  • Please log in to reply
11 replies to this topic

#1 layasamadhi

layasamadhi

    Advanced Member

  • Members

  • 44 posts
  • Country: Country Flag

Posted 20 April 2014 - 02:44 PM

Basically I encountered this issue. Every time I refresh the page reappears the PageLines's logo and search box on navi(full). In practice I change the navi(full), hide the search box, replace the logo, public the changes and after page refreshing the disaster. PageLines's logo and search box reappear. 
 
I went crazy for two weeks. I tried to isolate the problem and in the end I found the accused plugin: Page{Less}.
 
When Page{Less} is off everything works. When active the problem persists.


#2 Evan Mattson

Evan Mattson

    Super Member

  • Members

  • 231 posts
  • LocationAnn Arbor, MI
  • Framework Version:latest stable & beta releases
  • Country: Country Flag

Posted 20 April 2014 - 03:02 PM

Greetings @layasamadhi,

 

I'd be happy to look into this for you, however I need some more information to begin.

 

  • Installed versions of DMS and PageLESS
  • When you say "navi" are you referring to the core NavBar section?


#3 layasamadhi

layasamadhi

    Advanced Member

  • Members

  • 44 posts
  • Country: Country Flag

Posted 20 April 2014 - 04:10 PM

Installed DMS 2.0.4 and PageLESS 1.2.3

 

With "navi" I mean the section Navi (Full) placed in the fixed bar.



#4 Evan Mattson

Evan Mattson

    Super Member

  • Members

  • 231 posts
  • LocationAnn Arbor, MI
  • Framework Version:latest stable & beta releases
  • Country: Country Flag

Posted 20 April 2014 - 05:07 PM

@layasamadhi

 

Unfortunately, I have been unable to replicate this problem.  Can you provide some more details to your steps to recreate this?  How would I recreate your problem starting from scratch? Does this happen on every page? or only pages with PageLess styles?

 

I have reviewed the code for the navi section and I don't see anything there that would conflict with PageLess nor vice versa.  I understand that you are only having this problem with it enabled though so let's see if we can get to the bottom of it.



#5 layasamadhi

layasamadhi

    Advanced Member

  • Members

  • 44 posts
  • Country: Country Flag

Posted 20 April 2014 - 05:28 PM

1) Place navi(full) section in the fixed bar.

2) Replace the logo

3) Hide the box search

4) Publish the customization

5) Edit the css with pageLESS (any element)

6) Refresh the page

 

The problem should arise. Sometimes it does not happen immediately, but after a several refreshes. I know, this is weird. In fact I went crazy for two weeks to look for what was to be incompatible.


#6 Evan Mattson

Evan Mattson

    Super Member

  • Members

  • 231 posts
  • LocationAnn Arbor, MI
  • Framework Version:latest stable & beta releases
  • Country: Country Flag

Posted 20 April 2014 - 06:16 PM

@layasamadhi,

 

Good news,  I can see what you're talking about now.  I don't know exactly what the cause is yet but I'm leaning towards a possible bug with DMS.  I've found that even though the settings seem to be wiped out, they are in fact still saved!  For some reason they are just not taking effect.  It's very strange.  I will keep digging into this and let you know what I find.



#7 layasamadhi

layasamadhi

    Advanced Member

  • Members

  • 44 posts
  • Country: Country Flag

Posted 20 April 2014 - 06:47 PM

Yea!   :) 



#8 Evan Mattson

Evan Mattson

    Super Member

  • Members

  • 231 posts
  • LocationAnn Arbor, MI
  • Framework Version:latest stable & beta releases
  • Country: Country Flag

Posted 21 April 2014 - 02:14 AM   Best Answer

@layasamadhi,

 

Hello again!  After doing some digging, I was unable to figure out exactly why things were breaking the way they were.  I don't really think my extension is to blame because my method of saving (which seems to be the culprit here) has not changed from older versions of DMS which had no problem before.  However, I believe I have resolved the issue now and I have just released an update (1.2.4) that should take care of it.

 

Please let me know if you continue to have any problems after the update.



#9 layasamadhi

layasamadhi

    Advanced Member

  • Members

  • 44 posts
  • Country: Country Flag

Posted 21 April 2014 - 09:31 AM

Wow that speed! 
Now I try if there are other problem. I'll keep you updated.
 
Thanks. 


#10 layasamadhi

layasamadhi

    Advanced Member

  • Members

  • 44 posts
  • Country: Country Flag

Posted 21 April 2014 - 12:47 PM

Now finding problems with the footer. 
The "social links" section disappears completely after the page refresh.
 
Even in this case is not recurrent. It's pretty random.
 


#11 Evan Mattson

Evan Mattson

    Super Member

  • Members

  • 231 posts
  • LocationAnn Arbor, MI
  • Framework Version:latest stable & beta releases
  • Country: Country Flag

Posted 24 April 2014 - 02:28 AM

@layasamadhi,

 

Are you sure this is related to PageLess as was before?



#12 layasamadhi

layasamadhi

    Advanced Member

  • Members

  • 44 posts
  • Country: Country Flag

Posted 24 April 2014 - 08:43 AM

Hi Evan.

 

No, I'm not sure. I'm trying to understand and isolate the problem. I'll keep you updated.






Also tagged with one or more of these keywords: PageLess, css, navi, logo, navi full, dms2