• 0

DMS 2 Changes Won't Show Unless Flush Caches Each Time


Question

Posted · Report post

Hi,

I'm working on a new site in DMS2 and have disabled all plugins except for DMS Plugin Pro and PL Updater.

Using Danny's Skeleton Child Theme, WP 3.9.3, DMS 2.0.4

I have a Chrome extension called "Cache Killer' on so I'm not seeing pages cached by my browser. 

 

In order to see my changes, I need to go to Resets and Flush Caches every time. 

I'm developing on my host's server rather than locally, for a couple of reasons, so I know that I should not use ('PL_LESS_DEV',true) on what is essentially a production site. 

 

Can you please tell me how I can see my changes without needing to Flush Caches every time?

 

Thanks,

Bruce

 

1 person likes this

Share this post


Link to post
Share on other sites

13 answers to this question

  • 0

Posted · Report post

install the developer plugin you can disable the caches

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Bruce, who's your host? They might have some form of caching enabled at their end.

 

Try using the alternate css urls option in site settings > advanced, this option was created to try and assist with hosts who have their own form of aggressive caching in place. http://screencast.com/t/1nzWm2lh

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks for the reply. My host is Web Hosting Hub. I checked in with their tech support, and they told me they do not employ server side caching. 

I tried the alternate css urls option, but it did not work.

Only Flush Caches works, which is a drag when I'm developing and want to see what each change looks like every few minutes. 

 

Do you think I should try a different host?

Does PL have recommended hosts that play nicely with DMS?

 

Or, maybe I need to bite the bullet and go back to developing locally w/ MAMP and see if I can figure out a good way to show clients remotely.

 

Thanks,

Bruce

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I went ahead and moved my dev site to MAMP, and found that I had the same problem... needing to Flush Caches in order to see each change. This of course makes no sense since I'm using MAMP, and especially since I put the define( 'PL_LESS_DEV', true ) code in my wp-config.php.

 

What I figured out is that DMS won't read my saves in Sublime, unless I Flush Caches.

When I copied my LESS from Sublime into the Custom LESS editor in DMS, I can see the changes without flushing caches.

 

Can you please tell me how to I can get DMS to read my saves from Sublime w/o needing to Flush Caches? Could this have anything to do with the Skeleton Child theme? 

 

Thanks,

Bruce

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm experiencing the same issue. LESS from the child theme will not recompile unless I manually click the flush butotn.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Simon_P,

Can you please tell me where I can grab the developer plugin?

Or, are you talking about the LESS Developer Plugin by Evan Mattson available for $20 on the store?

Thanks,

Bruce

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

It'll be in your my-account page on pagelines.com

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Simon_P

There is no Developer Plugin in My-Account.

How do I get it to show up?

 

Here's what is in My Account, in case you're interested: http://screencast.com/t/KSBP2ChN56

I didn't include a view of Pagelines DMS (Club Download) and DMS Business in my screenshot, since the keys are visible there.

 

Thanks,

Bruce

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post


 
Here's a screen shot
 
I've got the plugin installed now. But I can't find the option to disable LESS caching. I swear when I was first experimenting with DMS, I found that option. Any pointers?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

AHA! Finally found it. Hiding right in front of me. It's a button in the Visual Editor on the front end. The little wrench icon.

 

DMS%20Developer%20Options.png

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

balfred1345 - If you're experiencing this issues, then it is likely caused by one of the following:

 

  • A browser extension, please disable all of them.
  • A plugin, please disable all active plugins.
  • Make sure you do not have Section Cache active in DMS Pro Tools.

If doing the above doesn't resolve your issue, then its likely related to your server. Therefore, can you enable DMS debug mode ~ DMS Toolbar > Settings > Advanced and provide a link to the site in question, so we can see your debug information please.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I upgraded to developer, and installed the developer plugin. Enabled LESS dev mode, disabled Cache. This did the trick. 

 

Thanks.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks for informing us the issue has been resolved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now