Jump to content


Photo
- - - - -

Docker - custom post type


Best Answer jane , 16 April 2014 - 10:47 PM

EDIT:

 

@Martin Davies and @James B, I found the fix for this problem:

 

In the Settings section of Polylang, make sure this is checked: The front page url contains the language code instead of the page name or page id

 

I found this fixed my Navi search problem and apparently it was the fix needed to get Docker to work as well!

 

So if anyone is having problems with Polylang and DMS2, apparently this setting is very important to have checked.

 

Thank you

Go to the full post


  • Please log in to reply
8 replies to this topic

#1 jane

jane

    Advocate

  • Members
  • 347 posts
  • Country: Country Flag

Posted 02 April 2014 - 05:48 PM

Hi,

 

I think Docker will be  very useful for my site however I wanted to ask, what does pagelines recommend using as far as a custom post type plugin? Is there a plugin in that better than the rest?



#2 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 03 April 2014 - 02:22 AM

Hi there, alot of users use wp- types for custom post types - http://wp-types.com/...-custom-fields/



#3 jane

jane

    Advocate

  • Members
  • 347 posts
  • Country: Country Flag

Posted 03 April 2014 - 02:40 AM

Thank you @James B for the suggestion. There were too many to choose from so this help, thanks again



#4 jane

jane

    Advocate

  • Members
  • 347 posts
  • Country: Country Flag

Posted 03 April 2014 - 04:26 PM

It doesn't seem to be working properly., the sidebar is not visible - any advice on why that might be?

 

 

EDIT:

 

I found the problem. I'm using Polylang for translations and the Types plugin to create custom post types. When I went into the languages setting of Polylang and checked the box to activate language and translations from custom post types, it breaks the docker sidebar. When I unchecked that setting, the sidebar reappears.

 

This is a bit problematic since ideally the site should be fully bilingual.



#5 jane

jane

    Advocate

  • Members
  • 347 posts
  • Country: Country Flag

Posted 10 April 2014 - 03:33 PM

Hi I have another update to this.

 

So as I explained above Polylang seems to conflict with the Docker. Today I noticed though that all the posts I created under my custom post type now were showing as 404 pages.

 

I went into Polylang and reselected the box to activate language and translations, and the content reappeared however the sidebar disappeared.

 

Any feed back?



#6 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 16 April 2014 - 04:29 AM

Hi there, is the page still using the same template as the page with the sidebar on? Are you able to drag and drop the sidebar back into position in the editor from the add to page section or does it vanish completely?

 

PolyLang will have separate pages for different languages. So you'd need to have a Docker section set up for each language, on each page.

 

If you're able to screenshot or screencast the process you're following this will help the moderator team in diagnosing the issue for you.



#7 jane

jane

    Advocate

  • Members
  • 347 posts
  • Country: Country Flag

Posted 16 April 2014 - 03:10 PM

Hi @James B thanks for stepping in to offer your assistance.

 

First, I should clarify that when I say "sidebar" I'm referring to the sidebar created by Docker...perhaps a better phrase would be vertical menu?

 

I understand that Polylang needs separate pages which is what I was doing (at least I'm fairly certain that is what I was doing!)

 

EDIT

 

Here's a link to a screencast of the problem I've been having:

 

 

  • I created a custom post type
  • made it translatable
  • added a new post
  • published the post and applied my docker template to the page
  • went back into edit to click the link to create the French version of the post
  • clicked publish and view and got a 404 page


#8 greenfly

greenfly

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 16 April 2014 - 10:44 PM

Could we have a link to your site please?



#9 jane

jane

    Advocate

  • Members
  • 347 posts
  • Country: Country Flag

Posted 16 April 2014 - 10:47 PM   Best Answer

EDIT:

 

@Martin Davies and @James B, I found the fix for this problem:

 

In the Settings section of Polylang, make sure this is checked: The front page url contains the language code instead of the page name or page id

 

I found this fixed my Navi search problem and apparently it was the fix needed to get Docker to work as well!

 

So if anyone is having problems with Polylang and DMS2, apparently this setting is very important to have checked.

 

Thank you