• 0

DMS 2 DMS 2 not installing on multiuser WP installation


Question

Posted · Report post

Website: http://www.SteverRobbins.com

Subsite: http://www.SteverRobbins.com/test1

Framework version: DMS 2

Wordpress version: 3.8.1

Plugins in use: Akismet, Blubrry PowerPress, Contact Form 7, Jetpack 2.9.2, Greg's High Performance SEO, PRO Player, Quotes Collection, RB Internal Links, Shiba Media Library, Widgets on Pages, Wordpress Connect, Wordpress Database Backup, WP Hide Post

Server/host: www.atof.net

Screenshots (attached)

 

My website http://www.SteverRobbins.com has a few subsites http://www.SteverRobbins.com/articles and http://www.SteverRobbins.com/getitdoneguy which are implemented as a Wordpress multiuser site with two subblogs. (The reason for this are historical. These were separate blogs that were merged, but each had a different Permalink structure and the only way to forward old links to new ones was to give the subblogs different permalink structures too.)

 

I have installed DMS 2 in the Themes library, and have selected DMS 2 as the theme for a newly created /test1/ sub site. In the theme selection page for the sub site, the preview thumbnail is broken.

 

[attachment=2094:Theme preview from subtheme Screen Shot 2014-04-02 at 8.06.46 AM.png]

 

I activate DMS 2 on the sub site, but the graphics continue to be broken.

 

[attachment=2095:Subtheme DMS activated Screen Shot 2014-04-02 at 8.19.34 AM.png]

 

Visiting the sub site in Chrome and attempting to edit the sub site produces just the "DMS Loading" then the "Oops there may be an error" screens.

 

When I visit my /test1/ dashboard, I see the "Click to install the Pagelines Updater plugin." I click to install and get an "Unexpected error" screen.

 

I tried to install Pagelines Updater by uploading the ZIP files directly. It uploaded correctly. I clicked Network Activate and got the the error: You do not have sufficient permissions to access this page. with the URL box showing: http://www.steverrobbins.com/wp-admin/network/index.php?page=pagelines_updater

 

I've stopped here. In short, the graphics appear broken, the sub site itself can't be edited. I can't install the Pagelines Updater plugin from my network plugin administration screen.

 

 

Share this post


Link to post
Share on other sites

11 answers to this question

  • 0

Posted · Report post

Could you enable debug on all your sites and sub sites please and let us know when you have done this. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

How do I enable debug? I didn't know there is a debug option anywhere.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi there, you can enable debug from the wp toolbar > site settings > advanced > enable debug then publish

 

http://screencast.com/t/R7rDBEQDZi

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I clicked the "Site Settings" button and nothing happened :-(

 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

you have to check the debug box inside site settings, like in the diagram in the post above. Once that box is checked add ?pldebug to the end of your url to see your debug page.

 

Example: http://www.steverrobbins.com/test1/?pldebug

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Did you upload all the files? Every one of the js files is a 404.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

 

you have to check the debug box inside site settings, like in the diagram in the post above. Once that box is checked add ?pldebug to the end of your url to see your debug page.

 

Example: http://www.steverrobbins.com/test1/?pldebug

 

Sorry. I was unclear. I click "Site Settings" and the site settings do not display. Nothing happens. No site settings appear. 

I definitely uploaded every file. I installed in the top-level of a non-multiuser Wordpress installation on the same host, using the exact same installation folders, uploaded with the same FTP client.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

... and ... Just for jollies I deleted the theme again and re-uploaded it AGAIN from the exact same file. And this time (the 3rd try), it seems to have worked. I have absolutely no idea what changed between my last attempt yesterday and my attempt today. 

Apologies for taking everyone's time. Whatever was going wrong seems to have vanished. Thank you for responding.

Share this post


Link to post
Share on other sites
  • 0

Posted (edited) · Report post

Oops. The Pagelines theme is activating, but the Pagelines Updater plugin is weirdly wedged. I deleted it, reinstalled, and clicked Network Activate. It gave the error "You do not have sufficient permissions to access this page." The URL in the menu bar was: http://www.steverrobbins.com/wp-admin/network/index.php?page=pagelines_updater

 

I go back to Network Plugins and it now shows Pagelines Updater as Network activated. YAY!

 

Now I go to the dashboard for my sub site and click "PageLines" admin button (not the "PageLines Pro" button). Under tab PageLines DMS Settings, section Your PageLines Account, there's an option that says "Activate Your Account" and it shows Site Not Activated. Clicking on the "Activate Your Account" link does not appear to do anything.

 

I am completely puzzled as to the state of PageLines. I'm guessing that my database got corrupted somewhere in all of this. I have no idea how to reset everything (theme & plugins) and try again. 

 

*Boggled*

 

I turned on DEBUG and the DEBUG info says:

 

DMS Debug Info

WordPress Version
3.8.1

WordPress Debug
Disabled

Multisite Enabled
Yes

Current Role
Administrator

Framework Path
/u/s/stever777/websites/www.steverrobbins.com/docroot/wp-content/themes/dms/dms

Framework URI
http://www.steverrobbins.com/test1/wp-content/themes/dms/dms

Framework Version
2.0

PHP Version
5.2

PHP Open basedir restriction
Yes! This can cause issues if it is not setup correctly
/u/s/stever777/:/tmp/

PHP Magic Quotes gpc
Yes! Deprecated as of PHP 5.3 and removed in PHP 5.4

PHP memory
256

Mysql version
5.0.95-log

PHP type
Cgi-fcgi

PHP User
Stever777

OS
Linux

Installed Plugins
jetpack/jetpack.php
pagelines-updater/pagelines-updater.php

 

« Back

Edited by Stever

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Your debug information shows that you're using and older version of PHP, we'd advise speaking to your host to get them to upgrade to 5.4 and if possible removing the base directory restriction.

 

PHP Open basedir restriction
Yes! This can cause issues if it is not setup correctly

 

If you want to start again and remove the db's then your host would probably be able to wipe these as well so you can do a complete reinstall of WP and then install DMS V2 again into each sub site.

Share this post


Link to post
Share on other sites
  • 0

Posted (edited) · Report post

Is there reason to believe that "You do not have sufficient permissions" would be fixed by installing a new PGP and then completely reinstalling Wordpress? I purchased DMS to *save* work and time and hassle, not to force me into an entire reinstall of my system in conjunction with my ISP (assuming they're even willing to install a newer PGP). This sounds like several hours' work (easy in theory, fraught with problems in practice), and I'm reluctant to take such a nuclear option just under the theory that "a reinstall will probably fix it." Indeed, valuing my time at any reasonable amount, doing this kind of reinstall would be more expensive than just giving up on DMS and going with Webflow.com for a year.

 

 

 

Your debug information shows that you're using and older version of PHP, we'd advise speaking to your host to get them to upgrade to 5.4 and if possible removing the base directory restriction.

 

PHP Open basedir restriction
Yes! This can cause issues if it is not setup correctly

 

If you want to start again and remove the db's then your host would probably be able to wipe these as well so you can do a complete reinstall of WP and then install DMS V2 again into each sub site.

Edited by Stever

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now