• 0

DMS 2 Making Content Area White so background doesn't show on text

Question

Posted · Report post

I have a background image on my page but its interfering with how the text looks.

 

I'd like the entire background of the content of the site to just be white and not have the background showing through.

 

How can I do that? In the old pagelines I had a little css I would throw in each site to make this happen.

 

Here is how it looks:

 

mess.jpg

 

Here is how I'd like it to look:

 

ideal.jpg

Share this post


Link to post
Share on other sites

12 answers to this question

  • 0

Posted (edited) · Report post

is this possible to do?

 

this should probably be in the customization forum. can we move it over there?

Edited by imagineutopia

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

.drag-drop-editing .pl-sortable-area, .drag-drop-editing .pl-sortable-column {
background: #fff;
}
 
In your custom CSS

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I've added that css but it didn't have any effect.

 

when that is the only css in there I am getting no background color still.

 

no.jpg

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

If that isnt working then try referencing with a custom class, from your Custom CSS/LESS (I prefer always to add to the Pagelines > DMS Fallbacks >Custom CSS/LESS in the wp admin) such as:

 

.whitecontent {
  background: #fff;
}
 
Then for each section on the page, add, under the standard options > Custom Styling classes:
 
 whitecontent
 
More laborious than the previous suggestion, which worked using Chrome developer..
 
 
 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm able to get it to work in the editor now but when I go to the live site its still not showing the color.

 

looks good in the editor using just this: 

 

.drag-drop-editing .pl-sortable-area, .drag-drop-editing .pl-sortable-column {
background: #fff;
}
 
Anybody know why the live site would be ignoring this CSS that the editor is displaying correctly? 
 
who.jpg

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Apologies... should look at what I pasted in. shouldn't have .drag-drop-editing in there as that would be for when editing only

 

This is what you should have, if in Custom CSS/LESS

 

body.display-full .pl-content {

background-color: #fff;
}
 
The custom class "whitecontent" can also be used and referenced as mentioned above.
 
 
Which, of course, makes much more sense! Sorry I have mucked you about... long day

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

thanks for your help. doing it in one big bulk like that is causing other areas to mess up but I think making the whitecontent as a class should work.

 

thanks.

 

again.jpg

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Did the class method work for you?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

yes kind of but I am getting gaps in my items from time to time.

 

what can I do about all these gaps? are there paddings I need to manually be removing from items?

 

http://184.154.227.20/~localsta/

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

yes kind of but I am getting gaps in my items from time to time.

 

what can I do about all these gaps? are there paddings I need to manually be removing from items?

 

http://184.154.227.20/~localsta/

Canvas area settings > Set area padding > 0px

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

this also helped me with my problem.... took me a long time to find how to get white content background. 

 

yay! 

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Good to know this helped :) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now