• 0

Scroll Nav section uneditable when set to right blueprint

Question

Posted · Report post

Dear bestrag, finally I got around to implementing Scroll Nav. Thank you for updating it to DMS2 - I started with the old version which conflicted with other plugins but now it's working well. And it's fantastic! Just what I have always wanted. But somehow I have fallen into a trap: I want icons only on the right side. So I choose an icon (Chevron Down for example), set colours for active and non-active states, save and refresh and there it is, on the right, working beautifully. But now I can't edit the section! Presumably because I have no text as you do in the demo, the pencil symbol to edit the section moves out of reach beyond the window's edge on the right whenever I touch it with the cursor. It is puzzling. I consequently cannot do anything but delete the section (the symbol to do that is on the left so I can click on it, as I can on the next three. Only the edit pencil - the most important one! - is inaccessible. Can you replicate this? Or am I doing something wrong? I hope it will be easy to fix, otherwise I always have to start from scratch (though presumably once I know all my settings I can set it up perfectly in the first place so that I don't have to edit afterwards...).

 

Thanks for your support and patience, and for writing this great section! Yours faithfully, Jan.

Share this post


Link to post
Share on other sites

12 answers to this question

  • 0

Posted · Report post

P.S.: Earlier today one of the Pagelines support staff recommended Jing for screengrabs. It looks promising and I managed to make a little film showing my predicament but I can't read the video format it uses (.swf) in order to change it into something I can upload on a website. All I managed to do was send the file to myself with WeTransfer. This is the link, if it is any good to you, I am sure you can play the Jing video...

https://www.wetransfer.com/downloads/e36c4fe710631444609644274e210e9920140331170405/49e414299f22b8c1a4ddd41fee356bef20140331170405/be1733

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

you don't need to upload anything - you can share the link to the video via jing and then paste the link into the forum post. 

 

Downloading .swf video but can't play it for some reason. 

 

Here is help with jing http://www.techsmith.com/tutorial-jing-record-video.html

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

http://screencast.com/t/gGdqStAz37jb

Simply amazing, Martin! "Your capture has been sent and the link is ready to be pasted". If only all Wordpress woes were as visual as this particular one (which rather comically brings to mind one of the very first Youtube videos I've ever seen, back in 2007 as I just confirmed... http://www.youtube.com/watch?v=yUdpj3gJofQ!). Thank you again for the Jing and now the Screencast.com advice. It will be a great help in the future I'm sure! Yours faithfully, Jan.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Dear Jan,

first of all I am really happy you like it and find it useful. I see what happened. I assume you used scroll nav fixed, either way this problem should not occur. 

I will try to replicate this problem and will come with solution very soon. 

 

Yours faithfully, bestrag.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks, bestrag. In your own time - it is working for now, and it will take me a week or two to progress on the site anyway. Greetings, Jan.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Dear bestrag, do you remember this problem? "Edit this section" being unclickable when I have Scroll Nav fixed to the right side of the screen? I am once again working on sites with Scroll Nav, but every time I want to edit something in Scroll Nav I have to remember all the old settings and imagine the new ones (such as a new or smaller icon), delete the section from the page and then put it in again, with the new settings. If everything looks the way I thought it would its fine - the section as such works beautifully! - but if I still want to change even one little bit, I have to go through the entire process again, because of the aforementioned bug. It would be a great convenience if there were a solution to this. Thanks for your help, yours faithfully, Jan.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hello, Jan.

 

I will fix that in 24 hours.

 

regards,

Bestrag

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Dear Bestrag - no rush! I'm already happy to hear that it seems easily fixable. I would usefully deplay ScrollNav from Friday... Thank you for your quick response. I look forward to scrolling and navigating with greater ease soon - and perhaps to present projects, if I can close that lightbox easily...

Yours faithfully, Jan.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hello, Jan.

 

Sorry for delay. Update is released (ver. 3.4.2) that handles this issue.

 

Regards,

Bestrag

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thank you, Bestrag. I appreciate this very much and look forward to give my sites the magic scroll touch again! Yours faithfully, Jan.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Dear bestrag, the fix is very elegant and works perfectly! Thank you so much. Greetings, Jan.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Happy to help.

 

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now