• 0

Menu problem in framework


Question

Posted · Report post

Hi All

 

Ive got framework installed and although im used to using wordpress, im having issues with making pages work in the menus.

 

Ive added the page in the menu where its supposed to be, and the pages themselves are set to have parents etc but they arent showing up correctly

 

the menu bar has the smoking page at the top and its not set for there, also the clinic address has a drop down page set but isnt showing either??

 

what am i missing??

 

thanks

 

Screen_Shot_2014_03_28_at_11_07_01.png

 

Screen_Shot_2014_03_28_at_11_11_21.png

Share this post


Link to post
Share on other sites

12 answers to this question

  • 0

Posted · Report post

ive done it Martin, ive faffed about with the menus and its ok now

 

thanks anyway, very helpful of you all as always

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

HI,

 

There is no issue, this is by design. The Fixed Navbar and NavBar section are designed based on Bootstraps navigation, where parent items become anchors and are no longer linkable. Meaning that when you have a menu item that has a drop down menu, the parent becomes an anchor, where you click it to access our submenu.

If you do not like this design, I highly recommend you upgrade to DMS, which includes a number of different menu options include a section called Navi, which features MegaMenu functionality.

 

You can see a demo here - http://themes.pagelines.com/dms/

Share this post


Link to post
Share on other sites
  • 0

Posted (edited) · Report post

Hi Dan

 

Thanks for that, im stil la bit confused though - how come i have already got certain pages to be subpages then??

 

Does frameworl mean that i cant have any more subpages than the ones i already have?

 

thanks

 

EDIT: im not sure were on the same page, im not talking about the page being an anchor -im referring to the fact that the smoking page is supposed to be a sub page but it wont move from the top nav

Edited by hypman

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Could you enable debug in PageLines > site options > advanced and paste a link to your site please? 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You debug information is available here http://ripley-hypnotherapy.co.uk/hypnotherapy-derby/?pldebug=1

 

Could you ask your host to remove the following or update your version of PHP to remove the following 

 

PHP Magic Quotes gpc : Yes (bad)

 

this is deprecated functionality and no longer needed in later versions of PHP and are known to cause problems 

 

http://www.php.net/manual/en/security.magicquotes.php

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

ok ill ask them and let you know

 

thanks

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

ok cool. please let us know how you get on 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi

 

they disabled magic requests but the issue is still the same??

 

What next? i dont understand how some pages can work as sub pages but others wont?

 

thanks

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

ok - if you could send us a logon for your site we can try to investigate this further for you 

 

The address to send to is hello at pagelines dot com 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Done that just now,

 

thanks for the help

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok great news. Thank you for letting us know :) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now