Archived

This topic is now archived and is closed to further replies.

  • 0

Banner problem : No feature posts matched this pages criteria

Question

Posted · Report post

Hi, I set a slideshow banner with feature posts on every header from my site. On the blog page, I got now difficulties to display it, it says : "No feature posts matched this pages criteria". I tried to disable the banner, and it disapears on everypage, I don't understand where the problem come from. Here's url : http://copagim.fr/blog/?page_id=121 Thx for help :)

Share this post


Link to post
Share on other sites

17 answers to this question

Posted · Report post

Travis, Thanks for your help, it helped me great. Now I just need to find my way to set a feature slider on the header of my posts page, from the subject of this topic :)

Share this post


Link to post
Share on other sites

Posted · Report post

I need to add something about sidebars in post page. The only way to make it desapear is to set "Fullwitdth" onto

platform pro settings > Blog & Posts > Posts Page-Content Layout

I still have difficulties to show what I want, sidebar comes in double, and differents kind of setting are not working on it.

Share this post


Link to post
Share on other sites

Posted · Report post

Actually, I set the banner in the Header section via Platform Pro settings. So it should displays on everypage, I just need my blog look the same on everypage. Last time you saw it, I just disabled it in page posts via "advanced settings", but I just enabled it back so you can have a look. And I checked, the good feature is also selected via admin, in page edit. Thanks.

Share this post


Link to post
Share on other sites

Posted · Report post

Hey Mary, Please explain what you're looking to do as clearly as possible. From your description it's impossible to help...

Share this post


Link to post
Share on other sites

Posted · Report post

Make sure that page is using the correct Banner Set, or none at all. Also, I keep getting this from your site.

This web site needs a different Google Maps API key. A new key can be generated at http://code.google.com/apis/maps/signup.html.

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks a lot, api key problem is setted now :) Actually, I setted the banner in my header section, and the problem comes only in the this page, and also search page and archive page.

Share this post


Link to post
Share on other sites

Posted · Report post

Okay, bumping for further developer help, bump again yourself please. Thanks, Bryan

Share this post


Link to post
Share on other sites

Posted · Report post

It seems that I have a problem with that page setted as a postspage in Settings>reading admin options : I can't modify my sidebar, and all the widgets displays. I tried everything I knew, and checked my template set up.

Share this post


Link to post
Share on other sites

Posted · Report post

Hey Arpowers, Sorry to be unclear. From my website http://copagim.fr/blog There's only single pages, except for "blog des administrateurs de bien" which is the posts page. What I need to do is simply manage the template in posts page and also all blog pages like I do on other pages. I'd like the same header, and like to choose wich sidebar (primary, secondary, tertiary) i put on the posts page and other blog page. The problem is the blog doesn't react in the same way as post page. I can't display my pagelines Feature (slider banner like other pages) : it always tells "No feature posts matched this pages criteria". For sidebars, If I leave the same options like in single pages, I got doubled content sidebar on post page, even if i check "hide" on every sidebar (primary, secondary...) while editing the post page threw admin. I can't decide which sidebar I want to display in posts page, search page, archive page. So it's a pity, but I had to put off feature and sidebars from the blog, as I can't manage like I would like. I hope my explanation is better now, sorry for my bad english. Thanks for support

Share this post


Link to post
Share on other sites

Posted · Report post

OK the problem resolves if I change reading options, posts page doens't accept my feature banner.

Share this post


Link to post
Share on other sites

Posted · Report post

We'll figure this out... for the posts page, do you have a feature-set selected?

Share this post


Link to post
Share on other sites

Posted · Report post

OK ! I got it. In order to have the same slideshow banner on my blog than in the rest of the website, i had to create a new feature set just for blog. But for blog (post page), the slideshow works only if you upload the pictures in "feature background image" instead of "feature media image" field while editing the feature. Thanks for your help.

Share this post


Link to post
Share on other sites

Posted · Report post

You have it set for the header area? ...and your posts page has the option set but it is not working? Let me look into this for you

Share this post


Link to post
Share on other sites

Posted · Report post

You're correct the posts page doesn't support 'meta options' So certain sections will have problems on this page... you could always go to `advanced setup > hide on posts page`

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks so much for ur answers. Does it means that it's impossible to use feature slider on post page, like on the rest of website ?

Share this post


Link to post
Share on other sites

Posted · Report post

Something else surprises me : even if i check "Hide on posts page" for EVERY SIDEBAR, I still have sidebar on posts page. Post page behaviour is really different from others pages for a beginner like me :) Thanks

Share this post


Link to post
Share on other sites

Posted · Report post

Mary, Having the sidebar on the posts page could be tied to your template you have chosen in your Platform Pro settings. In the wp-control panel, in the left column, under Platform Pro ==>Settings, Choose Layout Editor and then see what you have set as yor Default Layout Mode If that is set as having a sidebar then your blog page (aka posts page) will always have this layout. So if you want to have your blog page not have a sidebar then you will want to set the default layout to full width and then enable sidebars on your pages and post pages.

Share this post


Link to post
Share on other sites