Jump to content


Photo
- - - - -

Google Analyticator errors on server migration


  • Please log in to reply
3 replies to this topic

#1 sheilahoff

sheilahoff

    Advocate

  • Members

  • 505 posts
  • LocationSeattle
  • Framework Version:DMS
  • Country: Country Flag

Posted 08 March 2014 - 07:27 PM

I just moved my entire fleet of 40+ client sites from VPS to dedicated server. Propagation is complete. I was getting a lot of errors like this one:

 

 
Warning: require_once(service/Google_Utils.php): failed to open stream: No such file or directory in /home/hoffman/public_html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php on line 20

Fatal error: require_once(): Failed opening required 'service/Google_Utils.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/hoffman/php') in /home/hoffman/public_html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php on line 20

 

These sites were all working before the migration. In order to not have these errors I've globally renamed the plug-in folder to disable the plug-in so the sites all work again.

 

Now I need to know how to proceed. It seems like the move destroyed the authorization. I've already uninstalled and reinstalled to no avail. When I do that and activate I get the same error.

 

Any insights as to what's going on and the best way to move forward would be greatly appreciated. Running newest WP and plug-ins including v6.4.7.3 of Google Anaylitcator. I'm guessing there's something in the wpconfig or htacess but I'm no pro at this stuff. I'm hoping we can figure out a fix and then do it across all the sites. Otherwise I guess I'll just have to remove it and do without (or try a different tool). Such a shame. I bet it's something simple if you know what to do!

 

Thanks.


  • assomibatrifs likes this

#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17931 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 09 March 2014 - 11:35 AM

Sheila, those errors are related to a third party extension, this isn't something we provide support for, you will need to contact the author of the plugin.


  • assomibatrifs likes this

#3 sheilahoff

sheilahoff

    Advocate

  • Members

  • 505 posts
  • LocationSeattle
  • Framework Version:DMS
  • Country: Country Flag

Posted 09 March 2014 - 04:25 PM

Danny I'm well aware it's a 3rd party plug-in issue. I thought in this section called "Off Topic" it was OK to post anything, not just looking for official PL support. Sorry to bother you. Perhaps some of the community will have ideas. I did post this in their forum as well.


  • assomibatrifs likes this

#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 17931 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 09 March 2014 - 04:28 PM

I apologise, I didn't see it being posted in the General forum, I thought we had it set so that topics posted in this forum, didn't show in our que.


  • assomibatrifs likes this