Jump to content


Photo
- - - - -

edit.php (View All Posts) returns white page and error message


  • Please log in to reply
11 replies to this topic

#1 estebandraws

estebandraws

    Newbie

  • Members
  • 8 posts
  • Framework Version:2.4.4 Developer edition enabled
  • Country: Country Flag

Posted 03 March 2014 - 03:20 PM

From the Admin dashboard of Shopsos.com when attempting to View All Posts the action returns a white screen and this error message (I have debug and debug.log activated via wp-config)

 

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 80 bytes) in /var/www/vhosts/ShopSOS.com/httpdocs/wp-includes/cache.php on line 570

 

Additionally when accessing a post to edit from the front end (since its not possible from the admin panel) Screen Options is not functional, the text of the post is in white,  and Update post is not functional.

 

What I have done:

 

I deactivated all plugins, and removed a few that were showing errors in the wordpress debug log.  I attempted to switch themes (choosing a page lines theme) and the site became non functional.  I restored the site manually from a backup.  Deactivated all of the plugins again; exported my page lines settings; Switched to twenty-thirteen theme; reinstalled Framework 2.4.4 from a fresh download.  

 

Problem still exists.  Presently I have Akismet, Vaultpress, & Wordfence active plugins; the rest are deactivated.  Debug is enabled in the Pagelines dashboard.  

 

I am definitely missing something.  I need help in getting this site to work with Pagelines again.  Attached is the Wordpress Debug report from the Wordpress Debug plugin.  It has listed, I believe all of the software versions, active and deactivated plugins, etc.  

 

Wordpress version:  3.8.1

Pagelines Framework 2.4.4

php Memory allocation is set at 512M at the host

 

Thanks

 

 

 

 

 

 

 



#2 estebandraws

estebandraws

    Newbie

  • Members
  • 8 posts
  • Framework Version:2.4.4 Developer edition enabled
  • Country: Country Flag

Posted 03 March 2014 - 04:10 PM

I just realized that if any one on the team needs to debug this issue that all of the plugins need to be deactivated.  They are ALL deactivated now.  



#3 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 04 March 2014 - 12:02 AM

Hi there, looking at your error message you need to up the limit of the php memory. The problem you're experiencing is called 'the white screen of death' but the good news is that it can be easily fixed.

 

Please see the step by step guide on how to do this here -

Please Login or Register to see this Hidden Content



#4 estebandraws

estebandraws

    Newbie

  • Members
  • 8 posts
  • Framework Version:2.4.4 Developer edition enabled
  • Country: Country Flag

Posted 04 March 2014 - 01:24 AM

Ok, the documentation shows to set the PhP memory limit to 64MB in the wp-config file.

 

I've read about this before in the WP Codex.  What I have done was to set the PhP limit at the host to 512M.  So I should also set a PhP limit in the wp-config file at 64M even though I've set it to 512M at the host?  The error refers to: Allowed memory size of 268435456 bytes exhausted, which is 268 MB, correct?  



#5 estebandraws

estebandraws

    Newbie

  • Members
  • 8 posts
  • Framework Version:2.4.4 Developer edition enabled
  • Country: Country Flag

Posted 04 March 2014 - 01:27 AM

Thanks for the suggestion.  I want to be sure I understand the parameters.



#6 estebandraws

estebandraws

    Newbie

  • Members
  • 8 posts
  • Framework Version:2.4.4 Developer edition enabled
  • Country: Country Flag

Posted 04 March 2014 - 01:41 AM

I went ahead and edited the wp-config file with this line:

 

define( 'WP_MEMORY_LIMIT', '96M' );

 

I still have the same error message and white page when navigating to edit.php.  Same issues exist with edit a singular post.  No screen options, update post doesn't work and text is white.



#7 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 04 March 2014 - 02:14 AM

I'd say set that figure to 128 or 256 to test. The next step would be to speak to the host directly, some of them can restrict the php memory limit so even though you can manually change it in the php.ini or other files it still doesn't reach that level. Our Developer explains the hard limit set by hosts on this thread -

Please Login or Register to see this Hidden Content

for more info.

 

If your memory is that high though you should be well in the clear, check with your host to see if suhosin is active on your install, looking at previous posts this can exhaust the php memory.

 

Your PageLines debug shows the memory is set to 128mb as well as the following.

 

PHP User : Posix functions are disabled on this host!
PHP Open basedir restriction : Yes!

 

To bypass the posix functions try adding the following into your child theme or customize plugins functions.php file.

 

add_filter( 'render_css_posix_', '__return_true' );

 

The base directory restriction you will need to speak to your host above in order to remove. This stops files being read from higher up the directory. Who is your host?



#8 estebandraws

estebandraws

    Newbie

  • Members
  • 8 posts
  • Framework Version:2.4.4 Developer edition enabled
  • Country: Country Flag

Posted 04 March 2014 - 02:58 AM

Thanks.  I changed the wp-config file to 256M and it did not make a difference.

 

I can direct the question regarding the PHP User: Posix functions are disabled on this host as well as the PHP Open basedir restriction.

 

Are you saying that the Posix functions should be enabled (or otherwise add the line you wrote into functions.php)?  And the base directory restriction should be set to No?

 

If I am understanding, then what you are suggesting is that these two settings might be the problem and not really resetting memory.  

 

Its a VPS account at myhosting.com

 

I can certainly ask to have these settings changed.  But I would want to be sure to ask in an accurate manner.

 

Ask them:  to:  enable Posfix functions and to Set the base directory restriction to No

 

Would that make sense?



#9 Danny

Danny

    Is Awesome!

  • Moderators
  • 17666 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 04 March 2014 - 10:33 AM

Show your web host provider your debug info, they will know what problems to resolve. Also show them the error message you received regarding your memory issue. As this isn't something we can assist with, as the menu is set on the servers php.ini file. You will want to ask them to increase your memory to something like 256MB.



#10 estebandraws

estebandraws

    Newbie

  • Members
  • 8 posts
  • Framework Version:2.4.4 Developer edition enabled
  • Country: Country Flag

Posted 05 March 2014 - 08:26 PM

Greetings again!

 

I have contacted my host.  PHP memory has been increased, from my hosting provider:

 

I could see that currently memory linit was set to 512M. I have increased it to 1024M in php.ini file( /var/www/vhosts/

Please Login or Register to see this Hidden Content

). You can verify it from the following link.  

Please Login or Register to see this Hidden Content

 

They also enabled posix functions, and I believe that error has disappeared from the Pagelines Debug info screen

 

PHP Open basedir restriction : Yes! still shows up in the Pagelines Debug info screen.

 

This is what my hosting provider says about the Open basedir restriction:

 

>> It seems open base dir restriction is already set. You can verify it from the phpinfo page.

Please Login or Register to see this Hidden Content

 

We still have the same issues as before.  Nothing has changed for the better.  

 

Any suggestions regarding this new information to help us get this site fixed would be greatly appreciated.  

 

Thank you.



#11 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 06 March 2014 - 01:09 AM

Did you host advise if suhosin was active on your install? Whats the error message you're getting now on the memory exhaustion? Is it higher than before or the same?

 

Activate the PageLines Pro Tools plugin and in the pro tools admin use the test memory option -

Please Login or Register to see this Hidden Content



#12 estebandraws

estebandraws

    Newbie

  • Members
  • 8 posts
  • Framework Version:2.4.4 Developer edition enabled
  • Country: Country Flag

Posted 06 March 2014 - 01:20 AM

The hose did not provide the information on suhosin.  I will follow through on your suggestions, however.

 

Where we are now.

 

The host has taken care of the posfix and Open basedir restriction; They also increased the PHP memory as noted in an earlier post.  

 

Those settings did not in and of themselves fix the problem (but it did remove the error messages from the Pagelines Debug screen).  However, the support at my hosting provider just now added this line to the wp-config.php file:

 

define( 'WP_MAX_MEMORY_LIMIT' , '512M' );

 

At one point we had Defined the memory limit:  define( 'WP_MEMORY_LIMIT', '512M' );

 

Once define( 'WP_MAX_MEMORY_LIMIT' , '512M' ); had been added to the wp-config.php file then the error message went away and I can now navigate to view All Posts.  There are still issues, but at least now I can get to the screens.  There are issues in the categories section that I am cleaning up now.  We are still not entirely fixed, but with your assistance and that of my hosting provider, we have certainly made headway!  Thanks so much for all of your help.  I will be back with an update once I move through the rest of the issues I am seeing.  Thanks.