Jump to content


Photo
- - - - -

Remove Featured Image from actual blog posts?


Best Answer Danny , 21 April 2014 - 01:33 PM

Use it like this:

 

#site {
  .hide-my-image {
    .metamedia {
      display: none;
    }
  }
}
 
Then add hide-my-image to the Postloops Styling Classes field.
Go to the full post


  • Please log in to reply
19 replies to this topic

#1 frakture

frakture

    Member

  • Members

  • 24 posts
  • Framework Version:Business
  • Country: Country Flag

Posted 25 February 2014 - 10:25 PM

Hi there, wondering if there is a way to remove the featured image from the blog posts themselves. Looks silly that there are two of the same images in the blog post. Am I correct to assume that we need the featured image for the thumbnails in the flipper and post loop? Thanks!



#2 batman

batman

    Bat Learning

  • Members

  • 2218 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 25 February 2014 - 10:48 PM

Hi @fraktureP

Please, you can go in post loop on the blog post and you have the "Hide Thumb" option.

I add an image

http://screencast.com/t/FE4v6v3XFhv



#3 frakture

frakture

    Member

  • Members

  • 24 posts
  • Framework Version:Business
  • Country: Country Flag

Posted 26 February 2014 - 02:42 PM

Ha! Of course it's something so simple! Thank you for taking the time to show me. :-) 



#4 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 27 February 2014 - 06:23 AM

Well done Batman, thank you for updating the thread frakture.



#5 simplyport

simplyport

    Newbie

  • Members
  • 3 posts
  • LocationMichigan
  • Framework Version:DMS 2
  • Country: Country Flag

Posted 18 April 2014 - 03:52 AM

Does it not give you the option in DMS 2, or am I not looking in the right spot? 



#6 GetMeWebDesign

GetMeWebDesign

    Advocate

  • Members

  • 524 posts
  • LocationSurrey, UK
  • Framework Version:developer
  • Country: Country Flag

Posted 18 April 2014 - 08:24 AM

@simplyport. You need to activate the legacy mode to get DMS 1 control, or use custom CSS/LESS


  • simplyport likes this

#7 sethoof

sethoof

    Super Member

  • Members

  • 100 posts
  • Country: Country Flag

Posted 21 April 2014 - 12:14 PM

I have the same problem, but don't want to activate legacy as its not supported going forward.  But I am not sure what to write in the CSS.  I looked on firebug, but its not clear to me.  Is there a simple fix to turn off the featured image in custom post types for DMS2? 

 

Thanks,

Seth



#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 17966 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 21 April 2014 - 12:52 PM

To remove the Post thumb, add the following to your CSS.

 

#site .metamedia {
display: none;
}


#9 sethoof

sethoof

    Super Member

  • Members

  • 100 posts
  • Country: Country Flag

Posted 21 April 2014 - 01:11 PM

Thanks, Danny.  I just put this into my custom CSS:

 

.hide-image {
  #site .metamedia {
display: none;
}
}
 
then I listed the hide-image in the Custom Styling Classes field of the WP Content Loop, but the featured image is still displaying.  Am I doing something wrong?
 
Thanks


#10 Danny

Danny

    Is Awesome!

  • Moderators
  • 17966 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 21 April 2014 - 01:33 PM   Best Answer

Use it like this:

 

#site {
  .hide-my-image {
    .metamedia {
      display: none;
    }
  }
}
 
Then add hide-my-image to the Postloops Styling Classes field.

  • simplyport and sethoof like this

#11 sethoof

sethoof

    Super Member

  • Members

  • 100 posts
  • Country: Country Flag

Posted 21 April 2014 - 04:22 PM

Perfect, Danny.  Thanks again for your help!



#12 simplyport

simplyport

    Newbie

  • Members
  • 3 posts
  • LocationMichigan
  • Framework Version:DMS 2
  • Country: Country Flag

Posted 28 April 2014 - 11:07 PM

Thanks!



#13 dsolano

dsolano

    Advanced Member

  • Members

  • 37 posts
  • LocationTulsa, Oklahoma
  • Framework Version:2.3.3
  • Country: Country Flag

Posted 29 April 2014 - 01:51 AM

Very cool!

 

I just put hide-my-image in the Styling Classes field on one of my Pages and it removed the Featured Image.  

 

Thank you.



#14 Danny

Danny

    Is Awesome!

  • Moderators
  • 17966 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 29 April 2014 - 08:55 AM

No problem, when I finally finish the new docs, I will be sure to add little cool snippets like this into the docs.



#15 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 29 April 2014 - 05:24 PM


  • batman and GetMeWebDesign like this

#16 jane

jane

    Advocate

  • Members
  • 347 posts
  • Country: Country Flag

Posted 09 May 2014 - 02:19 PM

Is it possible to hid the featured image on one specific post as opposed to hiding it on all posts?



#17 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 09 May 2014 - 05:38 PM

Is it possible to hid the featured image on one specific post as opposed to hiding it on all posts?

Every post has a post class id, look at the page source and the <body> classes. 



#18 jane

jane

    Advocate

  • Members
  • 347 posts
  • Country: Country Flag

Posted 09 May 2014 - 06:02 PM

Hi @Simon_P,

 

So let's say I look up the post in question and its article id is 400. Would the following work?

 
.post-400 .metamedia {
  display:none;
                }
}

Or would I use the section id?

 

 

 



#19 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 09 May 2014 - 06:09 PM

Here is the body class of a post:

<body class="single single-post postid-1 single-format-standard logged-in admin-bar no-customize-support dms pl-pro-version responsive full_width pl-editor template-none display-full">

So if i want to hide metamedia on that post id use something like:

 

.postid-1 .metamedia {

    display:none;

}

 

Your snippet is invalid css, and also the postid format is wrong.


  • jane and GetMeWebDesign like this

#20 jane

jane

    Advocate

  • Members
  • 347 posts
  • Country: Country Flag

Posted 11 May 2014 - 03:01 PM

Thanks @Simon_P for helping me out