• 0

Unable to Write to Server Files


Question

Posted · Report post

I am still trying to get my site to write to the server and I ran the debug. Below is what I get. How can I fix this? Really appreciate the help folks! - Steve

DMS Internal Warning
Less Subsystem
Unable to set filesystem credentials

Share this post


Link to post
Share on other sites

5 answers to this question

  • 0

Posted · Report post

Do you have to add FTP username/password every time you update/install a plugin/theme? If so this is why, DMS does not know your credentials so WordPress will not allow it to write to your filesystem.

What PHP username is it running under? That would also have been on that debug screen.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Simon. Thanks for replying. I don't have to add the FTP info anymore. Here's the rest of the debug.

WordPress Version
3.8.1

WordPress Debug
Disabled

Multisite Enabled
No

Current Role
Administrator

Framework Path
/hsphere/local/home/compass1/compass-clinical.com/wp-content/themes/dms

Framework URI
http://compass-clinical.com/wp-content/themes/dms

Framework Version
1.1.6

PHP Version
5.2

PHP Register Globals
Yes! Deprecated as of PHP 5.3 and removed in PHP 5.4

PHP Magic Quotes gpc
Yes! Deprecated as of PHP 5.3 and removed in PHP 5.4

PHP memory
256

Mysql version
5.1.49-log

PHP type
Apache

PHP User
Httpd

OS
Linux

Licence OK
Skbigm@gmail.com

Installed Plugins
404-simple-redirect/404-simple-redirect.php
add-plain-text-email/add-plain-text-email.php
broken-link-checker/broken-link-checker.php
browser-specific-css/wp_browser_specific_css.php
bwp-google-xml-sitemaps/bwp-simple-gxs.php
cms-page-order/cms-page-order.php
contact-form-with-a-meeting-scheduler-by-vcita/vcita-contact-form.php
count-per-day/counter.php
dms-plugin-pro/dms-plugin-pro.php
exclude-pages/exclude_pages.php
google-analytics-dashboard-for-wp/ga_dash.php
google-analytics-for-wordpress/googleanalytics.php
google-sitemap-generator/sitemap.php
list-all-urls/list-all-urls.php
pagelines-customize/pagelines-customize.php
pagelines-lazyloader/pagelines-lazyloader.php
simple-share-buttons-adder/simple-share-buttons-adder.php
social-bartender/social-bartender.php
spam-free/index.php
spamtrap/spamtrap.php
subscription-options/suboptions.php
wordfence/wordfence.php
wordpress-debug/wordpress-debug.php
wordpress-seo/wp-seo.php
wp-content-copy-protection/fwpconsec.php
wp-db-backup/wp-db-backup.php
wp-fastest-cache/wpFastestCache.php
wp-optimize/wp-optimize.php
wp-pagenavi/wp-pagenavi.php
wp-smushit/wp-smushit.php

DMS Internal Warning
Less Subsystem
Unable to set filesystem credentials

« Back

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

PHP is running as user httpd. Thats why its running in fallback mode. There is no magic fix im afraid.

There are methods to add your login details to wp-config.php so you dont have to use FTP all the time.

chmodding the upload/pagelines folder to 777 *might* work other than that I dont know as your host is using a shared username of httpd :/

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I have removed the FTP access login issues but still get this error.

DMS Internal Warning
Less Subsystem
Unable to set filesystem credentials


And it relates to not being able to write to the server files. Any other suggestions to fix?

I've been struggling with this issue for quite a while. Any help is greatly appreciated

The entire debug is here:
DMS Debug Info

WordPress Version
3.8.1

WordPress Debug
Disabled

Multisite Enabled
No

Current Role
Administrator

Framework Path
/hsphere/local/home/compass1/compass-clinical.com/wp-content/themes/dms

Framework URI
http://compass-clinical.com/wp-content/themes/dms

Framework Version
1.1.6

PHP Version
5.2

PHP Register Globals
Yes! Deprecated as of PHP 5.3 and removed in PHP 5.4

PHP Magic Quotes gpc
Yes! Deprecated as of PHP 5.3 and removed in PHP 5.4

PHP memory
256

Mysql version
5.1.49-log

PHP type
Apache

PHP User
Httpd

OS
Linux

Licence OK
Skbigm@gmail.com

Installed Plugins
404-simple-redirect/404-simple-redirect.php
add-plain-text-email/add-plain-text-email.php
broken-link-checker/broken-link-checker.php
browser-specific-css/wp_browser_specific_css.php
bwp-google-xml-sitemaps/bwp-simple-gxs.php
cms-page-order/cms-page-order.php
contact-form-with-a-meeting-scheduler-by-vcita/vcita-contact-form.php
count-per-day/counter.php
diagnostic-tool/diagnostic-tool.php
dms-plugin-pro/dms-plugin-pro.php
exclude-pages/exclude_pages.php
google-analytics-dashboard-for-wp/ga_dash.php
google-analytics-for-wordpress/googleanalytics.php
google-sitemap-generator/sitemap.php
list-all-urls/list-all-urls.php
page-list/page-list.php
pagelines-customize/pagelines-customize.php
pagelines-lazyloader/pagelines-lazyloader.php
simple-share-buttons-adder/simple-share-buttons-adder.php
social-bartender/social-bartender.php
spam-free/index.php
spamtrap/spamtrap.php
subscription-options/suboptions.php
wordfence/wordfence.php
wordpress-debug/wordpress-debug.php
wordpress-seo/wp-seo.php
wp-db-backup/wp-db-backup.php
wp-fastest-cache/wpFastestCache.php
wp-optimize/wp-optimize.php
wp-pagenavi/wp-pagenavi.php
wp-smushit/wp-smushit.php

DMS Internal Warning
Less Subsystem
Unable to set filesystem credentials

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

The issue is the php username, apache.

 

No amount of trying will change that.

 

99% of shared hosts use fpm/fcgi now days, and you're php username is your login name.

 

Ask you're host if you can upgrade to a modern PHP SAPI instead of the ageing mod_php which they are using.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now