• 0

What version of WooCommerce are you guys running?


Question

Posted · Report post

Hi there,

Can I ask what version of woocommerce you are running on Pagelines?

I updated to 2.1.2 and they have removed certain pages and replaced them with 'ENDPOINTS', which are throwing up 404 errors.

In true woocommerce style the woo support team are blaming everything else rather than address the issue.

Despite me installing the 2014 theme and deactivating every plugin it still isn't working, I just wanted to see if you had 2.1.0 or higher working with DMS yet so I could tell woo support.

Any light you could shed would be helpful.

Cheers

Stuart

Share this post


Link to post
Share on other sites

8 answers to this question

  • 0

Posted · Report post

Haha, I found the problem.  Just in case anyone else comes across this i'll add it here.

 

Disable all plugins THEN reset Permalinks, I just went to Permalinks and resaved them.  Get the 404 page on another tab ready to refresh, once plugins are off and permalinks are reset, refresh your page, it should work.

 

Reactivate plugins one by one and refresh the page with the endpoint until you get the 404.  That's your plugin causing the issues.

 

Remember, reset permalinks AFTER deactivating your plugins otherwise you'll just get the 404's keep rolling.

 

My plugin was Nick Haskins and Co Projects Part Deux.  The second time this month it has caused me a headache...

 

Hopefully that will help someone in the future.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Just checked on the core site and we're using Version 2.0.20 currently. I've not heard anyone mention anything yet regarding Woo but they've probably not looked into the upgrade yet.

 

Checking with Woo, they issued the following. Copy/pasted below, sounds like flushing the permalinks should get everything back up and running.

 

If you need to roll back you can download the older version from http://wordpress.org/plugins/woocommerce/developers/

Lots of pages 404 error after WooCommerce 2.1 update

This issue is now resolved in the WooCommerce 2.1.1 fix release.

Because we have changed a couple static pages to endpoints in the WooCommerce 2.1 release, the permalinks need to be flushed. This wasn’t done properly in the WooCommerce 2.1 update, therefore you should do this manually in case you have a lot of 404 errors after updating. The upcoming 2.1.1 patch release will fix this issue and no longer requires a manual flush.

Pages included in possible 404 errors are: main shop page, category or tag archives and all of the new endpoints. This also affects conditional functions like is_shop() and that causes plugins relying on that function to no longer function properly.

You can flush the permalinks manually by saving the Settings > Permalinks page, to be found in your WordPress administration panel. After doing this, your pages will work as expected.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yeah, I wouldn't advise you upgrade, I've been through 2.1, 2.1.1 and 2.1.2, flushed my permalinks and switched themes and turned off every plugin, no joy.

Just wanted to see if anyone had 2.1+ working with DMS so I can be sure it's not the theme. I don't think it is.

Woo support still mysteriously quiet!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks for sharing.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Mid update here and having problems too - will post them in a separate post for future reference. Have rolled back but still affected - worst issue is the product category pages showing in one column.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Have you tried a quick theme change, that and switching off your plugins are the two quick checks.  Just remember to resave your permalinks once you've changed the theme and deactivated your plugins.

 

It would seem a lot of people are having theme issues, I have seen issues with Projects Part Deux, WP Videos and 404 Redirect plugins.

 

Good luck getting it sorted, it has been a nightmare.  WooThemes have not dealt with this upgrade well in my opinion.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I will try that but think I'm confusing things - I'm still using the Framework, not DMS - had arrived on your thread via another and did not check. Sorry about that. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now