• 0

I have a big problem


Question

Posted · Report post

Hi:

 

I have changed the domain of mi page, and I replaced the mentions of old domain in the database with the nett sql consult:

UPDATE wpfec_postmeta SET meta_value = REPLACE('meta_value', 'fundacioneuropadelosciudadanos.eu', 'europadelosciudadanos.net')
UPDATE wpfec_posts SET post_content = REPLACE('post_content', 'fundacioneuropadelosciudadanos.eu', 'europadelosciudadanos.net')
UPDATE wpfec_posts SET guid = REPLACE('guid', 'fundacioneuropadelosciudadanos.eu', 'europadelosciudadanos.net')

Now, when I enter to the page, (http://europadelosciudadanos.net) I meet the next message: 

 

Fatal error: Cannot use string offset as an array in /usr/home/europadelosciudadanos.net/web/wp-content/themes/dms/editor/editor.templates.php on line 141.

 

Can somebody help me?

 

Thanks

 

 

Share this post


Link to post
Share on other sites

5 answers to this question

  • 0

Posted · Report post

I hope you have a copy of your database before you nuked it.

 

The options under wpfec_postmeta would have been serialized data, by doing a blind replace like that you broke every settings array for every post/page.

 

You should have used a search/replace plugin that finds the options the deserializes then replaces then resaves them serialized again.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

HI,

 

Are you using Wordpress single or Multisite ?

What version of DMS and Wordpress are you using?

Also, this is likely an issue with your Wordpress setup now that you have changed domain, you will probably want to manually search your database to for any other existing values pointing to the old domain.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I am using wp 3.8.1 and DMS 1.1.6, and all worked fine until I made the change in the database.

 

I´ve downloaded the database, an there is not reference to the old domain.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yes, I had a copy of databaes, and  I´ve restored. Thanks.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yes, I had a copy of databaes, and  I´ve restored. Thanks.

Thats a relief! ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now