• 0
Sign in to follow this  
Followers 0

Page Content Disappearing

Question

Posted · Report post

Hello, I am entering html code on my homepage and I hit update.  Everything works fine when I publish the changes.   However if I switch the  tab from 'Text' to 'Visual' it automatically changes the information to an older version with lorem ipsum text.  I paste back in the correct information and hit publish and it shows correctly again.  But if I click on the visual tab it reverts back doing the same thing.   

 

I believe this has to be a theme issue as I never experienced this with other themes.   

 

I just updated to the latest version of wordpress. 

I am using Pagelines Frame work 2.4.4. 

 

The Site I am referring to http://www.legionsecurityllc.com/

CMS Info:  bossadmin / Cre@tive05 

 

Please help.  

Joe

bosscreative@gmail.com

210-835-8721

Share this post


Link to post
Share on other sites

10 answers to this question

  • 0

Posted · Report post

BTW:  here is the code that I paste in:
 

<div class="row doorway">

<div class="span4">

<a class="alarm imagesprite" title="Alarm System" href="/alarm-systems/"></a>

</div>

<div class="span4">

<a class="tech imagesprite" title="Tech Cameras" href="/ip-cctv-cameras/"></a>

</div>

<div class="span4">

<a class="voltage imagesprite" title="Whole House Audio" href="/whole-house-audio/"></a>

</div>

</div>

<div class="row home-text">

<h1>Welcome to Legion Security</h1>

Our mission at Legion Security LLC is to sell and install the best security and surveillance products in the security industry. Our knowledgeable and care team is dedicated to providing each client with the highest level of personalized customer service to your satisfaction. We are committed to your safety and granting you peace of mind.

</div>

 

 

 

After I click on the Visual Tab... it takes away the span4 image sprites and leaves me with:

<div class="row doorway">

</div>

<div class="row home-text">

<h1>Welcome to Legion Security</h1>

Our mission at Legion Security LLC is to sell and install the best security and surveillance products in the security industry. Our knowledgeable and care team is dedicated to providing each client with the highest level of personalized customer service to your satisfaction. We are committed to your safety and granting you peace of mind.

</div>

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You cannot switch from text to visual. This is a limitation of the WordPress editor.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I can not switch from text to visual?  I find this an odd answer.  

 

Do you mean this is a pageline theme limitation?  Because I have been doing this for years on my other websites.     

 

Please explain further.  

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

No it is not a PageLines limitation. The WordPress visual editor strips classes and invalid html when you switch from text to visual.

 

Use one or the other when creating posts and if you are going to use complex HTML then stick to text mode.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I still find this odd as I use even more complex code on my oter wordpress sites and never have this issue.  But all my other sites are not on Pagelines.  

Not sure what's complex about it.  Im just using a simple div with a bootstrap class structure.  

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

It does the same in the default WordPress theme im afraid.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Lol... Im not sure where you get your answers man but I am telling you I have NEVER (even with the wordpress default theme) have experienced this issue.  

 

If you answer is correct can you explain why I DONT have this issue with another wordpress/ pageline theme?  http://hotshottruckingtexas.com/    when I toggle back and fourth nothing breaks.  

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Your answers are inspiring me to never use the Pagelines theme if that is the best support you got.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Not trying to be disrepectful,  I just don't believe your answer is correct.   Perhaps you can get another admin for a second opinion.   

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I have uploaded a screencast of me pasting your html snippet into the WP Post editor with 2014 theme activated.

 

I don't know what else to suggest. This is a known WordPress limitation.

 

http://screencast.com/t/YpRkCZfWso

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0