• 0

Poppy not working on Firefox or Safari


Question

Posted · Report post

Hi, I have placed Poppy on one of my websites. It works great on Chrome. Unfortunately, it is not working on Firefox on Safari. Specifically, if you click the Poppy button on Firefox or Safari, nothing happens--no contact form pops up. Does anyone know how to fix this?

Thanks,

David

Share this post


Link to post
Share on other sites

22 answers to this question

  • 0

Posted · Report post

Can you supply a URL please.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Just seeing a cached page, can you purge your cache and then turn it off please.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Simon,

 

Thanks for your reply. I clicked on "flush caches" in the  "Clear all CSS/LESS cached data" section of Resets.

 

How do I turn it off? 

 

Thanks,

David

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

FYI, I have not installed WP Super Cache or W3 Total Cache on this site yet. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

<!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

Served from: www.selborneproperties.com @ 2014-01-17 12:15:52 by W3 Total Cache -->

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Simon,

Thanks for your note. That plugin was not activated. I deleted it. I also flushed the caches again.

 

Thanks,

David

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Sorry still just seeing a cached page.

view source of the page and you will see the cache comments at the bottom.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Simon,
Thanks for your reply. I am unfortunately a pagelines novice. What should I do to get poppy working on all browers? I don't have any of those cache plugins installed or activated. Not sure what to do.
Thanks.
--David

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

The problem here is that you did have a cache installed, and when you uninstalled it you left the cache folder and the .htaccess rules in place, so I and everyone else se a cached page, and the cached pages are not being updated/flushed because you deleted the plugin.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Simon,

 

I am sorry for the inconvenience. What do you suggest that I do? Should I reinstall the plugin?

 

I am hopeful that I can get this fixed. If anyone can explain what I need to do so that you all can see what you need to see, I would greatly appreciate it. 

 

Thanks,

David

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi there, yes reinstall the plugin and activate. Inside the plugin menu you'll see an option in the settings to flush the plugin cache, use this to clear the cache it has previously installed. Some cache plugins have internal settings to deactivate before you fully deactivate the plugin inside the plugin tab so check the documentation for what your version of the plugin says etc. Once the cache is fully cleared you can go back and deactivate the plugin then delete.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

James,

 

Thank you for your note. I appreciate the explanation. I flushed plugin cache. I then deactivated and deleted. Can you all now see what you need to see re: Poppy not working properly on certain browsers?

 

Thanks,

David

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

How exactly are you adding the button? What code have you used?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Simon,

 

I added Poppy to a text box within a column. This is the textbox title -- [poppy type="button" class="btn-primary btn-large"]Sign up for online rent payment[/poppy]

 

It seems to work OK on Chrome, but Poppy is not popping up on other browsers. 

 

Link to the page of the site where this issue is occurring. It's the "Sign up for Online Rent Payment" button. http://www.selborneproperties.com/tenant-services/online-rent-payment/

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

http://pross.org.uk/this-is-brilliant/

Added your exact code to a textbox title, just like you did and it works in all browsers.

1. try updating to latest dms (1.1.5)
2. try turning off other plugins one by one, something is causing a javascript clash somewhere.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Simon,

 

I turned off the plugins one by one and it started working! However the plugin that was causing the Poppy issue was DMS Professional Tools. Poppy works fine in all browsers if DMS Professional Tools is deactivated. It does not work if DMS Professional Tools is activated. 

 

I'd still like to be able to use DMS Professional Tools, along with Poppy. What do you suggest I do?

 

Thanks,

David

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Which bit of it is breaking? There are various option in the plugin.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Simon,

 

I'm not sure what bit is breaking. I deactivated each plugin one by one. When I deactivated DMS Professional Tools, Poppy started working on all browsers. When I reactivated DMS Professional Tools, Poppy only popped up on Chrome. On other browsers it did not pop up. As a result, DMS Professional Tools is now deactivated, so that Poppy can work.

 

I am not sure I understand your last note. Thanks for clarifying.

 

--David

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

The pro tools plugin adds a menu to wordpress admin, you can turn on/off various settings in the plugin.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Simon,
Turning off section caching in the pro tools plugin fixes the problem. What do you suggest I do so that I can have that option enabled and poppy working at the same time?
Thanks,
David

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

The caching makes minimal difference anyway unless your site uses an OPCODE cache like memcached or APC. Id just leave it off, as it says in the disclaimer it a case of 'use at your own risk' ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now