Jump to content


Photo
- - - - -

The finnish language-file (fi_FI.po/fi_FI.mo) seems to have the wrong name

language translate

  • Please log in to reply
2 replies to this topic

#1 ketri

ketri

    Super Member

  • Members

  • 172 posts
  • Country: Country Flag

Posted 16 January 2014 - 05:40 PM

After several tests the translations only start working if the file has a name fi.mo, and won't work if the filename is fi_FI.mo

It's also possible that I'm missing something here. But indeed in the wp-config.php the line to set the language to Finnish is just

 
define ('WPLANG', 'fi');


#2 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 16 January 2014 - 05:50 PM

The filename must match whatever WPLANG is set to.

#3 ketri

ketri

    Super Member

  • Members

  • 172 posts
  • Country: Country Flag

Posted 16 January 2014 - 09:28 PM

The filename must match whatever WPLANG is set to.

I see. And both 

define ('WPLANG', 'fi'); and define ('WPLANG', 'fi_FI'); are probably correct?

I think it could be a good idea to change what's there by default, as the official Finnish WordPress -version has 
define ('WPLANG', 'fi'); in the wp-config.php and the information requred to get this work was really hard to come by (trial and error for hours) :) 

Thank you for your reply.







Also tagged with one or more of these keywords: language, translate