Jump to content


Photo
- - - - -

DMS theme not recognized in localhost installation

localhost mamp

Best Answer Simon_P , 13 January 2014 - 06:28 PM

If you have MAMP running under your username/group you wont run in to these issues. Go to the full post


  • Please log in to reply
12 replies to this topic

#1 gabelloyd

gabelloyd

    Advanced Member

  • Members

  • 42 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 11 January 2014 - 06:45 PM

I've Googled for the past hour on this, but I feel like this a really n00b question.  

 

Background: This is not my first website, but first Pagelines.

Platform:  WP 3.8

Theme:  DMS

Pagelines:  free

Local setup:  MAMP, php 5.5.3

Process of "loading files" on my local environment:  Drag theme folders into the "wp-content/themes" folder.  (this is how I work locally without problem, usually)

 

Goal:  Install DMS Theme for a local working environment, add a child theme.

 

I've downloaded the installed the DMS theme (free).  At first, I just loaded this to an existing project.  When I did not see the DMS in the Appearance> Themes area, I thought "Well, maybe the existing installation is conflicting with it?".  

 

I loaded the site to a test server and I was able to load the theme using the "upload a .zip file" method (not loading the file using my FTP client directly into the themes folder).  This works.  Hm.

 

I decided that I should try installing the DMS locally on a fresh install of WP.  Installed on a new database, new theme folder, again the DMS theme is not recognized.  Hm.  So, I loaded the base child theme I found on Github:  https://github.com/b...icks-base-theme by copying these files into my themes folder, and THAT showed up (but of course is saying that it's parent theme 'dms' is not found).  

 

I'm stumped.  Can I not drag theme folders into the 'wp-content/themes/' folder for local installation?  Did I miss something in the documentation about working locally?  

 

Thanks for your help!

 

 


  • Maidul likes this

#2 gabelloyd

gabelloyd

    Advanced Member

  • Members

  • 42 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 11 January 2014 - 09:58 PM

*sigh*.  I actually bought a developer license since I came across this forum post:  http://forum.pagelin...plan-localhost/  However, even now that I have unlimited installs available, I'm still getting nothing on the local machine.  


  • Maidul likes this

#3 Danny

Danny

    Is Awesome!

  • Moderators
  • 15145 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 12 January 2014 - 11:59 AM

HI,

 

Not sure what your issue is.

 

I have about 30 installations of DMS using MAMP ?

 

What do you mean by can I not drag the themes folder into wp-content/themes/ ?

If you extract the zip for DMS so you're ended up with a folder called dms, then simply drag and drop this into your local installations wp-content/themes folder, then go to your local site Wordpress Admin Dashboard and hit refresh or go to Appearance > Themes, DMS should now be available.

 

If this isn't possible, can you provide screenshots of your local sites wp-content folder and themes folder please.


  • Maidul likes this

#4 gabelloyd

gabelloyd

    Advanced Member

  • Members

  • 42 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 12 January 2014 - 06:28 PM

Hi Danny,

 

I know, this seems ridiculous.  To clarify your question about "dragging my themes folder into wp-content/themes/", I did mean that I uncompress the dms.zip file that I download from Pagelines, and then drag that 'dms' folder into the wp-content/themes/ folder.

 

This morning I cleared the dms folder and the child theme I was attempting to setup on my localhost, redownloaded dms from Pagelines from the /my-account/ page, uncompressed the dms.zip file, dragged it to the wp-content/themes/ folder and still nothing.  

 

I've posted some images of my setup on Github:  https://github.com/a...20f8ebd5e534ee3

 

Thank you for your help.



#5 Danny

Danny

    Is Awesome!

  • Moderators
  • 15145 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 12 January 2014 - 10:09 PM

Do you have any plugins active, if so disable them. I would also make Twenty Thirteen your default theme with all plugins disabled and then clear your browsers cache, history etc.. Then see if DMS is available in Appearance > Themes.

 

If that doesn't resolve your issue, where did you download DMS from ? PageLines.com or GitHub ?

If GitHub, attempt to download/install via the Wordpress theme installer the DMS version from PageLines.com



#6 gabelloyd

gabelloyd

    Advanced Member

  • Members

  • 42 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 13 January 2014 - 04:12 AM

Disabled plugins, disabled and deleted other themes.  Made Twentythirteen the active theme.  Cleared the cache, history.  Emptied the trash, restarted the computer, still nothing.  

 

I've downloaded the files directly from Pagelines.  

 

How am I the only person this is happening to?



#7 Danny

Danny

    Is Awesome!

  • Moderators
  • 15145 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 13 January 2014 - 12:10 PM

I have no idea, why DMS isn't being recognised, if you have MAMP up and running, with Wordpress running just fine, then when you install DMS, it should be available in the themes folder. I have no issue whatsoever with my DMS local sites running through MAMP.

 

Have you installed using the Wordpress theme installer ? 



#8 gabelloyd

gabelloyd

    Advanced Member

  • Members

  • 42 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 13 January 2014 - 02:39 PM

Well, on my local machine, I can't use the Wordpress installer because I get the FTP permissions error.  That's why I use the drag and drop method for my local devo environment.  

 

I'm going to try and uninstall the DMS copy on the remote testing server and see if that clears anything up.  The only thing I can think of is that because my first installation was the free version, somehow it's blocking any further installations, even though I've purchased a license.  



#9 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 13 January 2014 - 04:38 PM

The free version differs only slightly codewise.

Sounds to me like the user that php/apache is running under on your PC does not have permission to read the files you dragged into the themes folder.

#10 gabelloyd

gabelloyd

    Advanced Member

  • Members

  • 42 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 13 January 2014 - 06:07 PM

So, DMS needs to have different permissions than every other theme I've ever used?  If so, please let me know what the settings need to be for the user in order to view the dms theme folder.



#11 gabelloyd

gabelloyd

    Advanced Member

  • Members

  • 42 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 13 January 2014 - 06:26 PM

Holy moly!  I was Googling around for changing MAMP permissions.  I came across a few posts about changing permissions on files, which I didn't think I needed to check since I already set the 'themes' folder to 777.  It never occurred to me that the 'dms' folder itself would have it's own permissions that needed to be changed.  Not only did they need to be changed, but the file was set to 'NO ACCESS' by anyone, not just 'Read Only'.  I changed it to 'Read & Write' and viola!, it's available and works!!  Whoo hoo!!

 

For anyone else Googling this and needs to know how to change file permissions on a Mac:

  1. In Finder, select the 'dms' folder under your 'wp-content/themes' folder.
  2. Type 'Command + i'
  3. This brings up a dialogue box.  Unlock the box by clicking the locket icon in the lower corner.  You'll need your computer password to do this.
  4. Once unlocked, under 'Privileges', select the privileges you want to change.  Working on your local machine, choose "Read & Write". 
  5. Close the dialogue box.


#12 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 13 January 2014 - 06:28 PM   Best Answer

If you have MAMP running under your username/group you wont run in to these issues.

#13 gabelloyd

gabelloyd

    Advanced Member

  • Members

  • 42 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 27 January 2014 - 03:49 PM

Hi guys,

 

You can mark this as solved.  I would do it, but I don't see the button for some reason.







Also tagged with one or more of these keywords: localhost, mamp