• 0

Responsive Sidebar: Don't show at certain size


Question

Posted · Report post

http://theeargazm.com On my single posts I'd like the side bar to disappear at a certain size. As you can tell, when you make the window small, the side bar covers the post. I know that this is plug in related, but if i could make the sidebar in general not function or disappear at a certain size, it would solve the issue. 

Share this post


Link to post
Share on other sites

11 answers to this question

  • 0

Posted · Report post

Hi Bentley

 

You'll need to use @media to hide the side bar at a set screen size. Change the screen size to fit when you want it to vanish.

 

@media (max-width:930px) {

ul.sidebar_widgets {
    display: none;
}
}
1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Which browser are you seeing this in? 

 

I look at this page http://theeargazm.com/listen-ceo-wonderland/ and i do not see this happening - the sidebar does dissapear and does not cover the post. 

 

Am i looking at the wrong page? 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

VEry odd - i cannot replicate this - which browser are you using here - am i right in thinking it is Safari? 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Martin Davies Chrome all day everyday.. That's super weird you can't replicate. I have the same issue on mobile devices. That's where the issue actually became a problem.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Just a thought! Are you using any browser extensions?


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

this is how i see the site http://d.pr/i/WDFs

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Martin Davies It's on 3 different computers, an iphone and an ipad. On mobile devices it hovers over the footer when you scroll all the way down. It's not a browser issue..

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

James B That didn't seem to work..

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Nevermind. That worked great! Thanks again! James B

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You're welcome, glad it worked :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now