Jump to content


Photo
- - - - -

child theme LESS only works when logged in

less

Best Answer CliffordP , 23 January 2014 - 01:21 PM

@James B, you were right... odd.

 

I added #site {} around all the child theme's style.less code and cleared PL cache via wp-admin.

Went to the front-end and it was still all purple on purple.

Then I activated the PageLines DMS Editor, and the menu colors changed.

Then I signed out and signed in and activated and deactivated the Editor and it stayed working.

Must have been due to adding #site{} around it all, although I thought we tried that before.

 

Thanks for helping.

Go to the full post


  • Please log in to reply
10 replies to this topic

#1 CliffordP

CliffordP

    Advocate

  • Members


  • 456 posts
  • LocationOklahoma
  • Country: Country Flag

Posted 09 January 2014 - 05:59 PM

http://avisualadvant...t/julieRealtor/

 

Some of the child theme's code is taking effect, but this is the code that is not working when logged out (but does work as desired when logged in): http://paste.pagelines.com/7be0blQh

 

Logged in: http://cl.ly/image/131Q3g2v0B1S

Logged out: http://cl.ly/image/3L3P1S2S0B1h

 

Any ideas?



#2 greenfly

greenfly

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 10 January 2014 - 12:51 AM

Hi Cliff 

 

Could you create us an admin logon for the site and send to hello @ PageLines dot com and we can jump on and take a look for you. 



#3 RiverRat

RiverRat

    Super Member

  • Members

  • 159 posts
  • Locationseattle
  • Framework Version:newest
  • Country: Country Flag

Posted 10 January 2014 - 01:51 AM

Thank you. Will do that.



#4 greenfly

greenfly

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 13 January 2014 - 03:54 PM

@clifford - do you still have a problem with the reported issue? i didn't receive an email from yourself regards this? 

 

@satinfeather99 - if you have a similar problem could you create a new topic and give us full details of the issue please and we can then take a look into this for you. 



#5 CliffordP

CliffordP

    Advocate

  • Members


  • 456 posts
  • LocationOklahoma
  • Country: Country Flag

Posted 14 January 2014 - 06:29 PM

I was assisting @satinfeather99 with her site. The issue and website are hers.

#6 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 15 January 2014 - 01:33 AM

Hi @satinfeather99, is the child theme called dms-realtor-julie. Is that where you're placing the css and saving? Looking in the source code the style.css for that child theme is showing but its currently empty. Please let me know where you're entering the css inside DMS. 



#7 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 22 January 2014 - 08:43 AM

Hi @satinfeather99

 

Have you managed to resolve this issue yet, checking the live site the code is showing the same logged in as logged out.

 

Logged in - https://www.dropbox....22 08.37.55.png

Logged out - https://www.dropbox....22 08.39.23.png

 

You need to re-add or tweak the code to adjust the text color inside the drop down menu.



#8 CliffordP

CliffordP

    Advocate

  • Members


  • 456 posts
  • LocationOklahoma
  • Country: Country Flag

Posted 23 January 2014 - 01:21 PM   Best Answer

@James B, you were right... odd.

 

I added #site {} around all the child theme's style.less code and cleared PL cache via wp-admin.

Went to the front-end and it was still all purple on purple.

Then I activated the PageLines DMS Editor, and the menu colors changed.

Then I signed out and signed in and activated and deactivated the Editor and it stayed working.

Must have been due to adding #site{} around it all, although I thought we tried that before.

 

Thanks for helping.


  • RiverRat likes this

#9 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 24 January 2014 - 06:12 AM

Hi Cliff, you're welcome, glad all is fixed :-)



#10 RiverRat

RiverRat

    Super Member

  • Members

  • 159 posts
  • Locationseattle
  • Framework Version:newest
  • Country: Country Flag

Posted 02 February 2014 - 05:13 AM

Thanks you guys! 



#11 Danny

Danny

    Is Awesome!

  • Moderators
  • 16376 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 02 February 2014 - 01:09 PM

Thanks for informing us the issue has been resolved.







Also tagged with one or more of these keywords: less