Jump to content


Photo
- - - - -

Feature loads at about 2x normal height, then shrinks back down

feature fade slider

  • Please log in to reply
21 replies to this topic

#1 angelopc

angelopc

    Advanced Member

  • Members

  • 31 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 08 January 2014 - 11:42 PM

I have a new website (new.svctx.com) that I'm building for a client. I've added a Feature to the header that doesn't seem to load correctly. Maybe someone could take a look and give me some advice?

 

Thanks!


  • assomibatrifs likes this

#2 Martin Davies

Martin Davies

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 08 January 2014 - 11:59 PM

I believe the feature slider loads the image and then resizes on page load to fit the aspect ratio in the feature slider settings. You can stop this happening by having the image the image the aspect ratio before uploading to the feature section. 

 

Could you take a screenshot of the settings for your feature slider image so we can double check for you,. 



#3 angelopc

angelopc

    Advanced Member

  • Members

  • 31 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 09 January 2014 - 08:48 AM

Here's what I get, with the settings I'm using.

 

Bad Feature:

Please Login or Register to see this Hidden Content

 

Good Feature:

Please Login or Register to see this Hidden Content

 

Settings:

Please Login or Register to see this Hidden Content

 

The image is 1024px X 220px. (4.654...)



#4 angelopc

angelopc

    Advanced Member

  • Members

  • 31 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 09 January 2014 - 08:51 PM

Any news on this issue, yet?



#5 Martin Davies

Martin Davies

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 09 January 2014 - 08:56 PM

Sorry i meant to ask for an admin logon for your site - could you create an admin level account for your Wordpress site and send the credentials to hello at pagelines dot com and i will jump on your site and check out your setup etc and find a solution for you. 



#6 angelopc

angelopc

    Advanced Member

  • Members

  • 31 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 09 January 2014 - 09:02 PM

Done.



#7 Martin Davies

Martin Davies

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 09 January 2014 - 09:05 PM

Thank you - i will take a look for your in a few minutes and update you shortly. 



#8 Martin Davies

Martin Davies

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 09 January 2014 - 09:46 PM

Could you try disabling all plugins and let us know when you have done this so we test something further.



#9 angelopc

angelopc

    Advanced Member

  • Members

  • 31 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 09 January 2014 - 09:49 PM

Disabled them all. Still does it. It just does it quicker.



#10 Martin Davies

Martin Davies

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 09 January 2014 - 09:56 PM

ok keep them disabled for us - taking another look now for you 



#11 Martin Davies

Martin Davies

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 09 January 2014 - 10:16 PM

Ok can you re-activate the plugins at any time now thank you. Another update shortly. 



#12 angelopc

angelopc

    Advanced Member

  • Members

  • 31 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 09 January 2014 - 10:18 PM

Cool.



#13 Martin Davies

Martin Davies

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 09 January 2014 - 10:39 PM

i just tested using jpeg's instead of PNG's and the performance is much much better. I set up an alternative feature set called test with the first slide made into a JPEG

 

Not a perfect fix but a definite improvement. 

 

not stopping looking at this but something to look at until i can get a colleague look into this ASAP for you. 


  • angelopc likes this

#14 angelopc

angelopc

    Advanced Member

  • Members

  • 31 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 09 January 2014 - 10:42 PM

Don't kill yourself over it. The site isn't even sold, yet. ;)

 

I'll check into creating the features with JPGs, instead of PNGs.

 

Thanks!


  • Martin Davies likes this

#15 Martin Davies

Martin Davies

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 10 January 2014 - 12:46 AM

Bit further research into this - i think it is to do with the DPI settings of the PNG's - just think they need to be optimised a little more. 

 

let us know how you get on :) 



#16 angelopc

angelopc

    Advanced Member

  • Members

  • 31 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 10 January 2014 - 09:57 AM

Yeah, I'm not sure that's the issue. I just brought them down to a third of their original file size and nothing changed. They were all at around 370kB-390kB. Now they're all at 120kB-130kB. No change.

 

I really appreciate your help on this. I hope there's a solution...somewhere.

 

The problem even exists on the About page, where no other photo gallery or slider/fader exists.

 

Update: I even shrunk the JPGs down to around 25kB-30kB, with no change to the problem.



#17 angelopc

angelopc

    Advanced Member

  • Members

  • 31 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 14 January 2014 - 12:19 PM

Hey, Martin.

 

Any updates on this? The site has actually been accepted by the client. Really looking to get this issue fixed, now.



#18 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 14 January 2014 - 10:57 PM

Hi there, the aspect ratio option resizes via a script which doesn't load until the page is fully loaded, which is why you see the original image first. Some users have found that if they have settings in the sitewide options and then different settings locally this can cause the resizing to be more prominent. You can check the sitewide settings in PageLines>page options>sitewide defaults.

 

Setting a static pixel size for the slider instead of using aspect ratio will prevent the slider from resizing as it won't be using the script to calculate the resizing, it will simple load at the given height and then if set to a responsive layout resize from that height downwards into mobile/ipad view etc.


  • wfws likes this

#19 angelopc

angelopc

    Advanced Member

  • Members

  • 31 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 14 January 2014 - 11:31 PM

I don't have a problem setting the static pixel size, but the image, itself, is being stretched. It isn't that the image is larger than the space that it fills (Feature is 220px high and so is the image).

 

Setting the static pixel height fixes the loading issue, though. Thank you.



#20 angelopc

angelopc

    Advanced Member

  • Members

  • 31 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 07 February 2014 - 03:51 PM

Hey guys...I have this issue on another site, but setting the Feature to Static renders it "unresponsive" (doesn't shrink).

 

DiannaSpieker.com

 

UPDATE: Actually, it doesn't work (is unresponsive) on the original site, as well.

 

UPDATE 2: It looks like I was able to fix this with the following:

 

.feature-wrap {
  max-height: 220px;
  max-width: 1000px;
}







Also tagged with one or more of these keywords: feature, fade, slider