Jump to content


Photo
- - - - -

500 Internal Server Error


Best Answer neilp , 30 December 2013 - 06:06 PM

My account had been hacked and my hosting provider needed to scan/clean and restore.

 

This is now resolved thanks. 

Go to the full post


  • Please log in to reply
13 replies to this topic

#1 neilp

neilp

    Advanced Member

  • Members

  • 51 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 28 December 2013 - 05:21 PM

Hi, 

 

I am a bit perplexed and looking for some assistance here.

 

The following error is displayed if I try and log into WP to update my site: 

 

Parse error: syntax error, unexpected $end in /home/k03grey/public_html/wp-content/plugins/dms-plugin-pro/dms-plugin-pro.php on line 184

 

This seems to have just appeared without there being any changes to my WP installation or any other setting (all was working fine before Christmas) additionally the same error is displayed from the public URL.

 

Address is: www.greyfinn.co.uk (de bugging is also enabled)

 

Any thoughts gratefully recieved.

 

thanks 



#2 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 28 December 2013 - 05:56 PM

Did you edit the plugin file?

Line 184 of that fil should read :

new DMSPluginPro;

 

its the very last line.



#3 neilp

neilp

    Advanced Member

  • Members

  • 51 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 28 December 2013 - 05:59 PM

Hi, 

 

thanks for your response - no I didn't.

 

Shall I just delete the pageline pro plug in and see what happens? (then reinstall)



#4 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 28 December 2013 - 06:05 PM

just go to the wp-admin plugins page, wordpress should disable it for you as the plugin has edited itself ;) Then remove it and re-install it.



#5 neilp

neilp

    Advanced Member

  • Members

  • 51 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 28 December 2013 - 06:10 PM

Thanks.

 

I can't log into wordpress at all - I just see the error message when I browse to the wp-admin page.

 

I have deleted the plug in pro plugin from the server.

 

However, when I try the wp-admin page now I get a different error: 

 

Parse error: syntax error, unexpected ':' in /home/k03grey/public_html/wp-content/plugins/w3-total-cache/w3-total-cache.php on line 68



#6 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 28 December 2013 - 06:14 PM

'Something' has obviously been writing to your plugin files.

 

Rename the plugins folder to plugins_old, and create a new empty plugins folder 



#7 neilp

neilp

    Advanced Member

  • Members

  • 51 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 28 December 2013 - 06:36 PM

Great thanks - I have done this and can now log into wp-admin.

 

When I select 'visit site' or browse directly to the URL I get:

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@greyfinn.co.uk and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.



#8 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 28 December 2013 - 06:39 PM

Did you visit the wp-admin plugins page?



#9 neilp

neilp

    Advanced Member

  • Members

  • 51 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 28 December 2013 - 06:54 PM

Yes, there are no plugins in there currently.



#10 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 28 December 2013 - 06:58 PM

Ok so, open wp-config.php and change WP_DEBUG from false to true, then the error will be revealed.



#11 neilp

neilp

    Advanced Member

  • Members

  • 51 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 28 December 2013 - 08:45 PM

Hi, 

 

I have opened wp-config and ('WP_DEBUG', true) is enabled. I cannot see any errors.

 

Thanks



#12 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 28 December 2013 - 09:21 PM

Well if WordPress debug wont show you the error, your gonna have to check the server logs like the error message says.



#13 neilp

neilp

    Advanced Member

  • Members

  • 51 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 30 December 2013 - 06:06 PM   Best Answer

My account had been hacked and my hosting provider needed to scan/clean and restore.

 

This is now resolved thanks. 



#14 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 31 December 2013 - 07:19 AM

Thank you for updating, glad you got resolved.