• 0
Sign in to follow this  
Followers 0

Remove padding above and below header


Question

Posted · Report post

Website URL: http://www.buddyflip.com/
Framework Version: 1.1.4
WordPress Version: 3.8
Plugins in Use:
DMS Professional Tools
Server/Host: your-site.com
Screenshots: Attached
Details: I have a "Media Box" with an image in it that I'm using in the Header of this site - and - I'd like to make the image go all the way to the top of the browser - and - I'd like to eliminate the padding beneath it - so that the nav bar is right up against the header image ... But - nothing that I've tried is working ... Any help would be appreciated.

 

Thanks!

Share this post


Link to post
Share on other sites

11 answers to this question

  • 0

Posted · Report post

If that suggestion didn't work, then it could well be plugin related. I only encounter the issue with CSS/LESS not saving every now and again, its not frequent like it is for some users.

 

So if the suggestion on the other topic hasn't resolved your issue, then its likely either a plugin or your custom code has some errors. 

 

What I would do is remove all your custom CSS and then add the code I provided above and see if it works, if it does then you could have errors in your code which is preventing anything after that error from working.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,

 

Add the following to your custom CSS:

 

#mediaboxuihxqp .the-media p {
margin: 0;
}
 
Also, you will need to edit the code you have used in the MediaBox to add your link and image.
 
At the moment you most likely have something like this:
 
<img style="border:0;" src="http://www.buddyflip.com/wp-content/uploads/2013/12/bf-header.png" alt="Buddy Flip" width="910" height="159">
</a>

Replace it with this:

 

<a href="http://www.buddyflip.com/"><img style="border:0;" src="http://www.buddyflip.com/wp-content/uploads/2013/12/bf-header.png" alt="Buddy Flip" width="910" height="159"></a>
 
Wordpress loves adding <p> or <br /> tags when you add a new line to text, code or shortcodes, this can cause some problems with output especially with HTML and shortcodes. Having your code all one line reduces this issue.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Danny - 

 

Thanks for your reply!

 

I added :

 

#mediaboxuihxqp .the-media p {

margin: 0;
}
 
to the custom CSS - and - also edited the code you have used in the MediaBox - and - neither seems to have done the trick ...
 
I'm stumped.
 
I'll keep on playing with it today to see if I can figure anything else out.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

The custom CSS from what I can see hasn't been added or loaded. I think what has happened is that you have come upon the issue that has effected a number of other users too.

Basically, what happens is you configure a section or in your case add custom CSS, then click publish, refresh and the custom CSS hasn't taken effect. This is a known issue and has been resolved and will be included in an upcoming patch 1.2.

 

For the moment, you can do this band aid fix.

What you need to do is this:

 

When you have added your custom CSS or configured a sections options, move your mouse cursor to either a different option field or in regards to adding custom CSS, click outside of the editor area. This will then trigger the Saving progression, you can confirm this by viewing the saving progression icon next to the Publish button. Once this saving progression expires, click the publish button and then refresh your site, your custom CSS should now be working as intended.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ah!

 

This will probably help to fix both of my issues ...

 

Although - I did it - and - no dice ...

 

Any idea when patch 1.2 will come out? 

 

I'm supposed to use Chrome - too - right?

 

I'm just glad that I'm not going crazy - adding code and nothing happening ... That is a minor relief!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You should use DMS Visual Editor with Chrome, we do not support other browsers when using the Visual Editor, even though you can trick the browser to think its a different browser.

When using the DMS visual editor you should always use Google Chrome, its the best browser by a country mile.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I totally agree about Chrome being the best ... It's the only browser that I use (unless I have to test something) ...

 

So - with the CSS not updating - is the theme caching the old code? I tried the work around that you laid out - but - it didn't "unclog" the CSS pipes and allow for the new code to come through ... Any other suggestions?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm having the same issue with mediabox. Interestingly enough, I don't have the same issue with the sliders. I have applied the fix, but it didn't work. I am using the dms editor in Chrome incognito mode to eliminate extension conflict. The site I'm working on is here; http://kcuthriell.wpengine.com/

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Toddlo, the padding for that area is coming from the class .pl-area-wrap  .pl-bg-cover both of which have 20px

 

http://screencast.com/t/Jln1nDisBu

 

Try the following to override the inline styles. Should look like this, flush to the top - http://screencast.com/t/62X8Zy83

 

.pl-area-wrap  .pl-bg-cover {

    padding-bottom: 0 !important;
    padding-top: 0 !important;
}
1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted (edited) · Report post

Howdy - on the initial site from this post (Website URL: http://www.buddyflip.com/) - I was able to to get the header to go flush against the top of the page - but - still haven't been able to get rid of the space between the top of the nav and the bottom of the header image ... Here is a link to a screenshot. 

 

http://www.screencast.com/t/wyXbaNHp

 

 

I just want the top of the nav to be flush with the bottom of the header image.

 

Any help would be greatly appreciated.

Edited by appappnost

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Basically, all sections contain some kind of padding/margin, the issue with your image and navigation not being aligned up, is due to there being padding top on the navbar section. To remove that padding top, use the following code.

 

#site .section-navbar .pl-section-pad {
padding-top: 0;
}

We do not provide extensive CSS support, so in future I highly recommend you inspect your site and elements using Google Chromes web dev tools. In this tool, padding is displayed as a green and margin is displayed as orange, so its easy to distinguish between the two. If you're new to the Chromes web dev tools, I recommend you check out the Code School online tutoring, which is awesome - http://discover-devtools.codeschool.com/
1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0