• 0

Drop down menu won't scroll past bottom of the page

Question

Posted · Report post

The title kind of says it all.  My site is www.bravemen.org.  The drop down menu item "About the Brave Men" drops down as it should, but I can't scroll down past what shows on the page (no matter if I use the down arrow or touch pad gestures).  All plugins, WP and themes (including Framework) are up-to-date.

 

Any suggestions?  Thank you !!

Share this post


Link to post
Share on other sites

3 answers to this question

  • 0

Posted · Report post

Actually - further to this. There may be some JS you could use to get the Nav menu to detect if it pushing past the screen. Some code you could use is outlined here http://stackoverflow.com/questions/3087122/detect-if-a-web-drop-down-menu-is-going-to-display-off-screen 

 

This would mean changing core code though and adding custom code which we wouldn't be able to support. 

 

I think Ubermenu provides a solution to this built in. http://wpmegamenu.com/

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Looks like there are so many entries to the drop down menu that whatever device the site is viewed on from my end (MB PRo, 27" iMac, Iphone) there is too much menu to fit not just in the browser but on the 'screen' itself. Personally i have never seen a drop down menu contain so many entries that this has been a problem. 

 

There are no options to deal with this in the navbar sections. 

 

I think the way it looks the options are to restructure the menu layout or use a more powerful menu section.

 

You could try breaking down the menu items into sub menu's - in the case A-D with the entries for those criteria in that sub menu. If you add more to the menu the way it is you are going to lose the bottom menu items as it stands. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thank you Martin!

This was never a problem with the old basic PageLines theme I was using, but with Framework, it won't scroll. I guess I'll have to reconfigure it to overcome this shortcoming...

Again, thank you!


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now