• 0
Sign in to follow this  
Followers 0

Navigation Menu Not Working on Non-Front Pages


Question

Posted · Report post

Hello,

 

Not the most experienced guy in the world here -- just an attorney who liked PlatformPro and purchased it to make a license-free site.

 

I'm having two problems.  

 

1. The first may or may not be new -- I think I would have noticed, but I'm not positive.  On the front page of the site, the navigation has dropdown menus.  Some of the child pages have their own children, even.  But for some reason, when I go to any other page, only the top-level pages are visible.

Front page: http://falseclaimsactattorney.com

Example of a page on which the dropdown menus are not working: http://falseclaimsactattorney.com/welcome-to-greene-llp/about-the-firm/thomas-m-greene-boston-false-claims-act-attorney/

 

I just tried replacing what had been a default menu with a custom menu, and that did not fix the problem.  Any ideas?

 

2. I have not updated to PlatformPro 1.6.0 -- but when I try to do so, I get a 404.

1 person likes this

Share this post


Link to post
Share on other sites

3 answers to this question

  • 0

Posted · Report post

Hi there,

 

Platform 1.6 can be downloaded from github on the following link - https://github.com/pagelines/platformpro

 

Did this work previously? Or was there something which triggered it like a wordpress update etc? I'd say upgrade to 1.6 in case there was a coding fix in there somewhere. I can see the sub menus appear in the source code but they just aren't being triggered on hover for some reason. To upgrade to 1.6 you'll need to install manually via appearance>themes.

 

Let us know if that has any effect :-)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I am also having a hard time with the static home page menus. I want to change my static page menu to an abbreviated version of the site menu. So I built a custom menu to use for the home page. Then, when I go into the menu editor, I change the primary website navigation to the home page menu. When I do this it reverts back to another menu I set called Main Menu. I have re-made the list, but that hasn't solved the problem, Any ideas for what I should do?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi there, if you have the menu in the header area make sure the changes you're making are in the local tab - http://screencast.com/t/qx2nTEa693

 

When you select the menu click in another area of the dms control panel so you see the spinning save icon in the top right of the dms control panel. Once this has stopped spinning, then publish and save.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0