Jump to content


Photo
Better iBoxes

Why do my iBox images keep disappearing?

images disappearing

Best Answer ahansson89 , 19 December 2013 - 10:44 PM

I think you are installing it the wrong way then.

You have to install it as a plugin and then activate it.

Upload the zip from the plugin screen in wp-admin and activate it. The plugin does the rest.

Go to the full post


  • Please log in to reply
9 replies to this topic

#1 wren

wren

    Advanced Member

  • Members

  • 60 posts
  • Framework Version:2.3
  • Country: Country Flag

Posted 17 December 2013 - 04:58 AM

There is a repeating problem with the images in Better iBoxes--for no apparent reason to me, my images disappear and then reappear at a later time. At first, I thought it was because DMS upgrades I did were causing me to have to re-load my Better iBox section. Every time that happened after re-uploading B...iBoxes, the text on my iBoxes would show up but it would take several days before the images would start to show again. 

 

Now I've just looked at my site and without having done an upgrade, my images have disappeared again. I don't know if this is because Wordpress just did an automatic update to 3.8 but that was several days ago and my images were showing up fine. Unless it was because my browser was reloading from my cache. Now I'm on a different laptop and my homepage isn't loading the iBox images.

 

This is killing my site as I designed my directory pages to use iBox images as selection buttons to the varying parts of my site. I've chosen to do this, creating a visual directory rather than using a conventional menu which worked great for me when I was using Framework with another 3rd party box plug-in. But that plug-in doesn't work with DMS. This is the 4th time my image buttons have gone down since I started using B...iBoxes. What's going on and how can I stop this from repeatedly happening?

 

Without consistent boxes, I'm going to have to totally redesign my site without iBoxes. That would be a bummer. 

 

As you'll see, the iBox text is showing but there are no images--

http://www.acmeworx.com

 

Help very much appreciated.



#2 wren

wren

    Advanced Member

  • Members

  • 60 posts
  • Framework Version:2.3
  • Country: Country Flag

Posted 17 December 2013 - 10:29 PM

Is anyone else having a problem with Better iBox only showing the text and not the images? With Firefox on a Mac and with Chrome on a PC the my site loads without the images. I'm going to test this on a few more devices to see what happens.

 

Still wanting help...



#3 quincy

quincy

    Newbie

  • Members

  • 2 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 18 December 2013 - 10:03 AM

I've got the same problem! I'm using the normal Ibox now and that works fine. Unfortunately less flexibel, but with images and text. 



#4 ahansson89

ahansson89

    Advocate

  • Members

  • 506 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 19 December 2013 - 01:24 PM

It is virtually impossible for php to read something out of MySQL that is not put there.

For whatever reason that the Better iBoxes sections switched places have nothing to do with the code and is not a bug.

 

I think that you simple did not publish the layout og there might have been a js issue that prevented the js to save.



#5 ahansson89

ahansson89

    Advocate

  • Members

  • 506 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 19 December 2013 - 02:32 PM

I have no idea why the image is not showing up. By looking at your site it seems like there is no height being parsed to the element, but in my tests and local installs the height is being parsed perfectly:

http://cl.ly/image/3A1A3F3i3g2n

Can you give me a screenshot of your settings so that I can replicate the exact setup?
 


  • wren likes this

#6 wren

wren

    Advanced Member

  • Members

  • 60 posts
  • Framework Version:2.3
  • Country: Country Flag

Posted 19 December 2013 - 10:31 PM

Attached File  Visual-directory-iBoxes.png   98.96KB   0 downloadsYes, isn't that weird about the images? I do see that you used one of my images in a test and it's just fine. All my images are in my database and they have shown up just fine since I started using Better iBoxes. But it seems like something gets broken when DMS does an upgrade. 

 

I'm so glad that I did take a screenshot back when I had it all going, I'll attach it. The other thing I can't figure out is why I got my layout all set up perfectly and then DMS gets upgraded, and in the upgrade it throws out my Better iBox section but keeps all the other sections intact in my DMS section directory. I tried installing Better iBoxes into my child directory but it didn't work from there. I could use some advice on where I can load in the BiB components so they don't get overwritten every time DMS does an upgrade. Maybe that would help solve the problem.

 

I do really like the added functionality with BIB and hope it might be something I can additionally customize to get even more functionality, i.e. images appearing on the right side or on the bottom of the text block. Before I started using DMS, I used a plug-in for boxes that is super sweet, here's the demo page of just a few of the cool box effects that were available before–– http://wpboxer.codin...b.com/examples/

 

Here goes with my screenshot...

 

Thanks so much!



#7 ahansson89

ahansson89

    Advocate

  • Members

  • 506 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 19 December 2013 - 10:44 PM   Best Answer

I think you are installing it the wrong way then.

You have to install it as a plugin and then activate it.

Upload the zip from the plugin screen in wp-admin and activate it. The plugin does the rest.


  • wren likes this

#8 wren

wren

    Advanced Member

  • Members

  • 60 posts
  • Framework Version:2.3
  • Country: Country Flag

Posted 19 December 2013 - 11:31 PM

OK, so I went through my ftp and deleted my old install of BiB. Then went to my wp-admin panel and uploaded my .zip. After activating it, I ran the two updates and crossed my fingers...

 

Sadly, I opened up my website in Firefox and Safari on my Macintosh and still no images in either browser. Chrome on the same laptop seems to permanently show my former page when I had it all working with all images showing but Chrome on my PC does not yield the images.

 

Very mysterious, but I will try re-making my boxes now that I have the latest update properly installed and will post my results tonight. 



#9 wren

wren

    Advanced Member

  • Members

  • 60 posts
  • Framework Version:2.3
  • Country: Country Flag

Posted 23 December 2013 - 11:02 AM

Mystery solved...

 

I was about to throw the towel in after reloading all my images, turning off all other plug-ins and even attempting to edit from Firefox. I learned that editing DMS can only happen using the Chrome browser. Try as I might, Chrome consistently showed changes I made to try and revive my Better iBox images and always showed the images while Safari and Firefox continued to not load.

 

Then I went wandering around the Pagelines varying sites and happened on a page called Pagelines Community dashboard...

http://pagelinescomm....com/dashboard/

 

Therein I happened on the free download of the Pagelines Academy Child Theme. It's really late, I thought I had tried everything and I also read that DMS is about to be upgraded to 1.2. I cringed at the thought of what that would do to my already terribly broken site. But since it's been terminally smithereened anyway, I decided to activate the freebie Academy Child Theme.

 

Then I restarted Firefox. Voila! Next I giddily reached my cursor over to Safari, the old snail...double voila! My bloody images are working beautifully in all three browsers. Haven't the strength to restart my PC tonight but my Mac is humming happily in three browsers with the new Academy Child Theme. Holy cow. I am one happy camper and very glad that my Better iBoxes laden site design does not have to be trashed.

 

I only pray that all goodness prevails beyond the next DMS upgrade.

 

Onwards and forwards, may we all rest well and develop gorgeous sites into the New Year. Cheers!



#10 ahansson89

ahansson89

    Advocate

  • Members

  • 506 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 28 December 2013 - 01:02 PM

I have no idea what you did, but happy that it helped. Closing this. Happy New Year.







Also tagged with one or more of these keywords: Better iBoxes, images, disappearing