Jump to content


Photo
- - - - -

Modified h1, h2 etc... in chrome


Best Answer Danny , 15 December 2013 - 11:38 AM

It is using the correct font as far as I can tell, its just that there is the following being loaded which seems to be effecting your custom font.

 

.thead, h1, h2, h3, h4, h5, h6, .site-title {
font-family: Georgia, "Times New Roman", Times, serif;
font-variant: small-caps;
}
 
If you disable the font-variant: small-caps; in your Chrome web dev tools, the fonts then looks the same as it does in FireFox (Safari for me looks the same as Chrome)
 
So adding the code I provided, should resolve the issue, I also can't see it in your custom fonts code when viewing your site.
Go to the full post


  • Please log in to reply
7 replies to this topic

#1 keithmagvacom

keithmagvacom

    Advocate

  • Members



  • 413 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 14 December 2013 - 12:38 PM

Hi 

Is anyone award of issues with modified titles displaying incorrectly in Google Chrome? 

 

From what I can see on my site

Please Login or Register to see this Hidden Content

the h1, h2 etc... are selecting the fallback font when displaying.

 

Where I have custom ID defined it works fine... In other browsers, Safari and Firefox the issue does not exist. Up untill recently it was working fine in Chrome also. The custom CSS I have used is:

Please Login or Register to see this Hidden Content

Thanks

 



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17533 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 December 2013 - 10:31 AM

Hi,

 

Where are these header tags which do not display your custom font ? When I view your site in Chrome they appear to be using the custom font ?



#3 keithmagvacom

keithmagvacom

    Advocate

  • Members



  • 413 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 15 December 2013 - 11:15 AM

Hi Danny

 

Thanks for looking. Here is where the H1 and H2's should be 

Please Login or Register to see this Hidden Content

 

The custom font is showing up correctly ("the vintage Craft of letterpress" and "create a lasting...."). Virtually the same CSS has been used for the H1, H2 and H4.

 

The H1 and H2 appear fine in other browsers and were working in chrome up to the last few days.

 

Thanks

Keith



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 17533 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 December 2013 - 11:27 AM

Add the following to your custom fonts CSS:

 

font-variant: normal;

 

This should resolve the issue.

 

Please Login or Register to see this Hidden Content



#5 keithmagvacom

keithmagvacom

    Advocate

  • Members



  • 413 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 15 December 2013 - 11:32 AM

Just tried it, no change. It seems to calling a fall back font!

Keith



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 17533 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 December 2013 - 11:38 AM   Best Answer

It is using the correct font as far as I can tell, its just that there is the following being loaded which seems to be effecting your custom font.

 

.thead, h1, h2, h3, h4, h5, h6, .site-title {
font-family: Georgia, "Times New Roman", Times, serif;
font-variant: small-caps;
}
 
If you disable the font-variant: small-caps; in your Chrome web dev tools, the fonts then looks the same as it does in FireFox (Safari for me looks the same as Chrome)
 
So adding the code I provided, should resolve the issue, I also can't see it in your custom fonts code when viewing your site.


#7 keithmagvacom

keithmagvacom

    Advocate

  • Members



  • 413 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 15 December 2013 - 11:48 AM

Danny, I have said it many times before, you are an absolute champ. I don't know were I'd be without you and the rest of the crew on forum. While my CSS is still rusty I have learnt so much from everyone. 

 

I adapted what you provided to: 

Please Login or Register to see this Hidden Content

and that has done the trick. Order has been restored to the site. 

Thank you



#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 17533 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 December 2013 - 11:49 AM

No worries :D


  • keithmagvacom likes this