Jump to content


Photo
Ultimate Social

Ultimate Social Missing Buttons with SSL



  • Please log in to reply
10 replies to this topic

#1 Brennum

Brennum

    Advanced Member

  • Members

  • 70 posts
  • Country: Country Flag

Posted 06 December 2013 - 12:25 PM

Hi, so I saw the other post about the missing icons (other than FB, Twitter, and email) and for me it's not due to a CDN. I've discovered that they all show with http:// but as soon as the site is in https:// all but the ones mentioned disappear. What needs to be done to fix this?

Thank you.

#2 Tom Hoey

Tom Hoey

    Member

  • Members

  • 20 posts
  • LocationAuburn, NY
  • Framework Version:2.4
  • Country: Country Flag

Posted 07 December 2013 - 11:07 PM

Hi, so I saw the other post about the missing icons (other than FB, Twitter, and email) and for me it's not due to a CDN. I've discovered that they all show with http:// but as soon as the site is in https:// all but the ones mentioned disappear. What needs to be done to fix this?

Thank you.

Same problem that I can see



#3 ahansson89

ahansson89

    Advocate

  • Members

  • 522 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 10 December 2013 - 01:09 AM

I will digg into this.

Not really sure why as I am not using any hardcoded links.



#4 Brennum

Brennum

    Advanced Member

  • Members

  • 70 posts
  • Country: Country Flag

Posted 11 December 2013 - 09:28 PM

Hey Aleksander,

 

So I looked into the server error logs and found this was an issue that came up:

 

mod_fcgid: stderr: PHP Warning:  curl_setopt_array(): CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in

 

.../plugins/ultimate-social/js/sharrre.php on line 65.

 

Also realized that I'm getting a 504 and 502 gateway timeout errors when this plugin is activated.

 

Definitely look forward to your help on this.

 

Thanks.



#5 ahansson89

ahansson89

    Advocate

  • Members

  • 522 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 12 December 2013 - 09:14 PM

Are you on a $1 hosting deal or something?

Seems like a hosting issue to me.

 



#6 Brennum

Brennum

    Advanced Member

  • Members

  • 70 posts
  • Country: Country Flag

Posted 12 December 2013 - 09:28 PM

Not at all. I'm actually on a dedicated server.

#7 ahansson89

ahansson89

    Advocate

  • Members

  • 522 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 13 December 2013 - 02:37 AM

try disabling safe_mode in php then



#8 Brennum

Brennum

    Advanced Member

  • Members

  • 70 posts
  • Country: Country Flag

Posted 14 December 2013 - 12:48 PM

That's not it either, safe_mode was already turned off. I'm afraid I won't be able to use this plugin, tried several configurations, on two different servers, and the same thing is happening. Can we just issue a refund on this plugin?

 

Thanks.



#9 ahansson89

ahansson89

    Advocate

  • Members

  • 522 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 14 December 2013 - 02:42 PM

What version of php do you have installed? Make sure you have 5.3 or above.

You might have to turn on Curl in php:
http://stackoverflow...ction-curl-init

Lets see if we can make it work before issuing a refund.



#10 Brennum

Brennum

    Advanced Member

  • Members

  • 70 posts
  • Country: Country Flag

Posted 14 December 2013 - 02:53 PM

I'm running all new versions of php. Turned off several security walls on the sever, and it's still not working. Sorry that this is all happening, but for me, a refund is better fitting. Thanks again.

#11 ahansson89

ahansson89

    Advocate

  • Members

  • 522 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 14 December 2013 - 03:11 PM

You have to email hello@pagelines.com to get a refund.

I still say it is a hosting issue as it is working fine for me and almost all other people. And it is probably because you do not have Curl enabled.







Also tagged with one or more of these keywords: Ultimate Social