• 0
Sign in to follow this  
Followers 0

Removing "Template" area from single page


Question

Posted · Report post

Hi Pagelines,

 

I'd like to embed a map fullscreen on a page on my website. When I do this, I alway have the small white area up top. (See attached image.) I'd like to remove that white area up top, so the map comes flush with the black header. Can you provide a tip on how to do this??

 

Here's a link to the site: http://rad.mosaicearth.com/mapbox-test/

 

Thank you for any help!

 

 

Share this post


Link to post
Share on other sites

8 answers to this question

  • 0

Posted · Report post

That space isn't coming from anything in DMS, its related to the plugin Sabai Directory, you will need to alter this CSS:

 

sabai-directory-nav {
margin: 0 0 1em;
}
 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi there, on that page there's padding-top applied to the classes below which you can remove. That will give this result - http://screencast.com/t/PenekPt1sO9

 

pl-area-wrap  pl-bg-cover

 

Then the rest of the white is coming from padding applied to another class. Remove this to get it completely flush - http://screencast.com/t/5x7k7oNYNfqy

 

.pl-section-pad

 

You can use the page-id prefix to your css to make sure any changes you apply on those classes only affect that page. The page id can be found at the top of the inspection panel for that page, for example yours would be page-id-641 - http://screencast.com/t/r62jGZhtgIFD

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi James,

 

Thank you for the help with this CSS. I spent the last 2 weeks studying up so I can make these changes and got stuck.

 

I've added the following code to my pagelines Custom CSS/LESS entry box: 

 

.page-id-738 .pl-section-pad {padding: 0px 0px 0px 0px;}

 

(Note the page id is now 738)

 

Although I understand that .pl-section-pad is the correct area to target, when changing to 0px padding (in chrome dev tools) nothing happens. I've tried this with and without the page id in there to check and that padding will not be removed! Is there something obvious I'm missing here?

 

See attached screenshot for reference.

 

The url of this page is rad.mosaicearth.com

 

Thanks very much.

 

 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Can you provide a link to the page that contains the map, so I can try and remove the padding myself please.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

The map is full width, so has the issue been resolved ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

No, it's always been full width.

 

Plz see the attached image... I'm just trying to remove the .pl-section-pad ... when setting padding to 0px, it still shows up.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Cheers, thanks so much Danny.

 

Ok, thread solved :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0