• 0
Sign in to follow this  
Followers 0

content disappearing from pages, columns reformatting


Question

Posted · Report post

I've been building a site without an issue but something weird has just started - I build a two column layout and add content (shortcodes/text etc) and save - the columns jump on refresh to a 12/12 with another column underneath and become unresponsive. I haven't added any plugins, not getting any LESS errors and never had this kind of issue before. 

 

I'm also adding sections and then finding after a refresh that they simply disappear. 

I disabled plugins and it was the same and then also stripped out all custom code, saved and it was the same problem. It's as though DMS has reached some kind of limit...

 

This is a page that I rebuilt, added a two column section but after saving the textbox turns into a 12/12 column and can't be adjusted. It also doesn't format and the textbox sticks to the left of the page. What I can't understand is why this has just started...

 

http://citywomen.org.gridhosted.co.uk/events-calendar/

 

 

Share this post


Link to post
Share on other sites

17 answers to this question

  • 0

Posted · Report post

Ok, so it seems that this weird behaviour was down to an expired event in the calendar that still had the checkout cart shortcode in the body (required for registration and payment).

 

The answer - remove the code from expired events. 

 

So fortunately nothing to do with DMS or my perfect CSS.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hello nfp1900

 

Please could you go to the Visual Editor - settings > Advanced > & click Enable Debug please? 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I did that already.

 

BTW the link above shows no content because I just checked and it's gone - it did have some content. It's as though it's no longer writing to the database. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I've been investigating this some more. If I load an existing template onto a page the content is visible but if I do a refresh then the content reflows. 

 

The only thing that I have done differently to other sites is save more custom templates than usual - I think there are 13 now. In the past I have used a fairly generic template and used CSS/classes to change colours etc. The fact that the page isn't holding a template leads me to think this could be the root of the issue?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I inspected the elements that shift location after saving which is part of the unresponsive column:

 

class="pl-section span12 offset0 section-textbox pl-sortable level2 sortable-first cant-offset"

 

"pl-sortable-column pl-sortable-area editor-row ui-sortable ui-sortable-disabled"

 

 

This was a 4/14 and 8/12 two-column section but is all over the place now: http://citywomen.org.gridhosted.co.uk/events-calendar/

 

 

Do you know what these mean? I need to get this finished in the next couple of days and this is really effing things up!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

From the looks of it, it appears that you're missing the following divs from your source.

 

<div class="pl-area-wrap  pl-bg-cover" style="">
<div class="pl-content  ui-resizable">
 
The pl-content gives the section area margin and pretty much positions your content in the center of your site, similar to how your header and footer are positioned. I am at a loss as to how these are missing from your section area.
 
I think you will need to remove all active plugins except for DMS Pro Tools and see if this resolves your issue. If that isn't the case, then remove all custom CSS and scripts and see if this does job.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Danny, I think I might have tracked it down, it seems to be the calendar bolt-on to the event system (by the same author) that causes the page reflow when activated. The weird thing is that it was fine before because I've given a demo of the whole thing to a client and it worked perfectly. 

 

The published page view in Chrome is also always fine - it's only when you view on another browser that you see there's an issue. It's also only affecting the page where the calendar shortcode appears in a textbox or postloop. 

 

How can I determine exactly what's causing this?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I think you would probably be best speaking to the developer of that plugin and see what he/she suggests, reply here when they do so please.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

They are saying this, is this something that PL is doing?

 

Are you minifying the CSS? I see a compiled-css-lots of numbers.css file.

 

I have had it before where minified CSS on a WordPress site can just make things explode for seemingly no good reason.

 

I would try and stop the minification and see if that resolves the issue.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I doubt its something we're doing, the issue is that you have two elements missing from what I can see like I mentioned above. 

Can you provide a link to the plugin so I can test this myself.

Also are you using shortcodes via text box in a 4/12 and 8/12 layout ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

It doesn't matter if I use the shortcode in the title of a textbox or in the postloop. The formatting looks fine to start with then gets messed up on a refresh. I can send you the two plugins that work in tandem, shall I email the zips to you?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

To be honest, its probably best if you send me both zips as well as your admin username password so I can see the issue first hand.

 

danny at pagelines dot com

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

ok, sent. Hopefully you'll find something dumb that I've done to cause this...

 

Thanks for checking it out

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

OK, there is definitely something effecting your layout, as some of your columns especially the BreadCrumb and TextBox, they shouldn't be full width like that.

However, you have so many plugins active, its difficult to tell if any of them are causing the issue.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

It only happens on the one page where the calendar appears. There aren't that many plugins active - 5 of them are for the event system and the others - nextgen, rev slider, contact form, bbpress, captcha etc are all pretty ordinary. 

 

You can load a new template and format the page, add the shortcode etc and it looks fine. Refresh and PL columns become unresponsive and reflow. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Exactly, so if that is happening it has to be related to a plugin, as that is not normal DMS behaviour. The BreadCrumb Nav and the TextBox near the Footer are fullwidth, those sections shouldn't be full width. Something is causing it, it could well be a plugin, a custom script.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

hehe, thanks for informing us the issue has been resolved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0