Jump to content


Photo
- - - - -

Primary website navigation bar does not change its language

menu primary language

Best Answer mdoblas , 22 November 2013 - 10:25 AM

Hi again,

 

Problem solved. I leave you the link where the solution is just in case you get any other question like mine.

 

http://wordpress.org...avbar?replies=2

 

In my case I had to add the mentioned code some raws down, but it worked.

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 mdoblas

mdoblas

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country: Country Flag

Posted 21 November 2013 - 05:40 PM

Hello,

 

I am creating an spanish / catalan multilanguage site, and I have a problem with the Primary Website navigation menu, which does not change when clicking on the language flag. It stays with the default language (catalan). I looked in the forum posts but I didn't find anything that could help.

 

Website URL: s408919052.mialojamiento.es This is a sandbox where I am building the website. Afterwards I will move it to www.educatcastellbisbal.es. If you have a look there, you will find already the website, but it is 1 languange only right now.
 
Framework Version: I am not sure about this. I guess you mean the theme version. It's 1.4.5
 
WordPress Version: 3.6.1
 
Plugins in Use: 
 
Language related
- Polylang 1.2.3
- WPML flag in menu 1.1
- WPML Flag in Menu Extended 1.2 This one was in use first but since it didn't work I deactivated it, allthough it is still installed. Now using the the WPML flag in menu 1.1 plugin.
 
Non language related
- Contact form 7 v.3.5.4
- Contact form 7 widget v.1.0
- Facebook v.1.5.3
- Google maps widget v.1.10
- Jetpack for Wordpress.com v.2.5
- Really Simple CAPTCHA v.1.7
 
Other plugins are installed but not active yet. 
 
 
Server/Host: db412100285.db.1and1.com
 
Screenshots: As you can see on the screenshots, the page and the boxes language change when clcking on the flag, but when I select the spanish version, which you can see with the catalan flag on the menu, the menu language remains in catalan.
 
I created the whole website without touching at anything on the code. I think this may be a problem with Polylang, but I am not sure about it.
 
Thanks a lot in advance.
 
 

Attached Files



#2 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 21 November 2013 - 10:17 PM

Hi there,

 

I've not used the polylang plugin but it seems to suggest you need to add the languages manually - http://wordpress.org...g/installation/

 

Have you checked with the plugin author to see if they're able to advise on what could possibly be happening? They have a support thread here - http://wordpress.org...plugin/polylang which could help



#3 mdoblas

mdoblas

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country: Country Flag

Posted 22 November 2013 - 10:25 AM   Best Answer

Hi again,

 

Problem solved. I leave you the link where the solution is just in case you get any other question like mine.

 

http://wordpress.org...avbar?replies=2

 

In my case I had to add the mentioned code some raws down, but it worked.



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 17666 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 22 November 2013 - 10:52 AM

Thanks for informing us the issue has been resolved, we appreciate it.







Also tagged with one or more of these keywords: menu, primary, language