• 0

Website speed issue


Question

Posted · Report post

Hey guys, sorry to be a pain again.

 

Recently set this site up from MAMP : localbustorbay.com/localbus

 

I believe it to be the host, but would hugely appreciate if somebody could check and confirm it's not something I havn't done optimisation-wise for the DMS.

 

All the LESS is in the style.less and I have the Pro tools plugin running too, and Cloudflare as well and minification.

 

Naturally this speeds it up a hell of a lot, but when the CDN is turned off and we are editing the site live (no cache) I am getting loading times of about 1 minute which is insanely slow for a 1.1mb sized webpage!

 

Thanks guys

Share this post


Link to post
Share on other sites

35 answers to this question

  • 0

Posted · Report post

when you click 'save' it should delete the 'active' one and create a new one.

 

Yea there should never be 700+ files there, there is something weird going on there. Maybe php cant find the files? perhaps its being restrcted somehow? Is there anything in the php logs?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Could you oh-so-kindly take a look please www.localbustorbay.com/localbus  :D

 

If you inspect elements and navigate around some of the pages, you will see the compiled-css that certain pages are looking for differs per page, and some find it fine, and others are looking for a completely different older .css file.

 

Perhaps something is being restricted, we are using Cloudflare and W3 TC, with minify turned off and rocketloader, along with the settings for Cloudflare on minimum while W3 has the usual set up.  This compiled CSS things has pretty much taken up our whole day trying to look into it haha, doing our heads in!

 

Sorry to lumber this on you, I just feel your knowledge of PL is so much greater than ours that you could perhaps see what it is we are missing here as it seems the compiled css is having some major issues for us.

 

You can still login with the previously sent info if you need to, we have enabled php debug now.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I have no idea what rocket loader is, id turn everything off except w3 cache and get that working right first

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

We have everything pretty damn fast now with CF and W3 TC, even if we don't have a clue what we are doing haha!  The residing issue however was the sites difficulty in finding the dynamic css file, so in the end I added my LESS, compiled the css, copied and pasted that into Nick's Child Theme stylesheet style.css and saved that as a fallback, which works.

 

I would still like to know going on how I would get over this issue though if you have any ideas. 

 

I am impressed with the DMS but have had serious issues with saving/writing settings to the DB using MAMP/AMPS, and even when live, I find that the system is very hit and miss in whether or not the settings/Custom LESS CSS actually saves.

 

LOVE the concept, but these issues seem to occur on the four installs I have tried so far which is a bit unsettling.  Id love somebody to say I'm doing something wrong but I don't feel there is much to go wrong locally on a fresh install?

 

(things like creating a home page template, saving it, then applying that to another page resulting in all the images on that page resetting to default and a lot of the text disappeared.)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Are the four installs all with the same hosting?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Two of the installs are local, and two are hosted on Heart 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Well i cant comment on local installs, impossible for us to support that, unless you want me to take a spin down there on the bike lol.

As for both remote installs they are both installed on the same shared hosting.

 

Im still convinced theres something funky going on with how they have PHP configured. Trouble is with cheap shared hosts they wont ever adjust their settings for one user. Thats why a VPS is always the best way to go IMO, and your free to do what you like then and if one site goes wild on the server and drains all the resources your site will remain online.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Right OK, take on board what you mean about the VPS and shared hosting!  Still seems odd that I am having the same issues across platforms with local and hosting, and the saving to DB is quite an annoying one.

 

Ooo yes please that would be excellent haha!  We can put the kettle on and get some snacks at the ready!

 

We have Nicks child theme installed under Pagelines at the moment, and suddenly we are having a php issue randomly popping up with Nick's Base theme which can only be resolved by renaming his theme to reset them.  Something about Fatal Error functions line 39 on nicks child theme with calling pl_add_theme_tab($options); string?  No idea what has caused that to pop up, I am attempting a complete delete and reinstall of the child theme but it was working fine earlier today.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Where abouts in Devon are you Simon?  Just curious we won't hunt you down! (honest)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Im in Tiverton.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now