Jump to content


Photo
- - - - -

email in post getting Spam

email public email privacy

Best Answer Danny , 18 November 2013 - 03:08 PM

Hi,

 

The reason as to why your email is being shown is because you have set your Wordpress username as your email address. You should never use your email address as a username for this very reason.

Therefore, I think the best course of action is for you to either add a Display name in your Wordpress profile or create a new user, make them an admin and do not have their username set as an email address.

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 gogeiger

gogeiger

    Member

  • Members
  • 18 posts
  • Country: Country Flag

Posted 18 November 2013 - 02:59 PM

On my blog it shows my email and I am getting spam.

 

Sample:

By gogeiger@comcast.net On November 18, 2013

 

  1. How do I protect myself from myself from spam?
  2. Do I want it removed?

 

Tim



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17533 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 18 November 2013 - 03:08 PM   Best Answer

Hi,

 

The reason as to why your email is being shown is because you have set your Wordpress username as your email address. You should never use your email address as a username for this very reason.

Therefore, I think the best course of action is for you to either add a Display name in your Wordpress profile or create a new user, make them an admin and do not have their username set as an email address.



#3 gogeiger

gogeiger

    Member

  • Members
  • 18 posts
  • Country: Country Flag

Posted 18 November 2013 - 03:44 PM

Solved

Thank you!



#4 greenfly

greenfly

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 18 November 2013 - 03:49 PM

Thank for letting us know 







Also tagged with one or more of these keywords: email, public email, privacy