• 0

Scroll Nav having trouble getting scroll nav to display

Question

Posted (edited) · Report post

hi.

 

I picked up a copy of scroll nav and am having trouble getting it to display.

 

I can't get it to do anything except it does show the back to top stuff if I turn that on.

 

I have added .scroll-header to my sections, and some dummy text in the options. is that the key is getting classes set in each section? I feel like there's more to it and I'm missing it.

 

nothing is showing in my preview or my real site. it is in the top header currently on my live site.

 

http://www.lexingtonsewage.com/

 

 

 

thanks,

Edited by imagineutopia

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

Posted · Report post

Hi.

at first, I was confused, because everything is in order. But when I looked again, I noticed that you added ".scroll-header" to styling classes of your sections. Only class name should be added there. Remove the "." and everything should work.

 

regards,

Bestrag

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hello, imagineutopia.

 

It appears that you have two Scroll Navs on your page: in header and after Highlight.

cloning of Snav is not supported because both would show the same menu items (which are generated automatically).

 

Try removing one of them  and then set SNav options (add title, subtitle and icon for three items - you added scroll-header class to iCallOut, Better-Iboxes and ProPrices).

publish and refresh, and you should see three menu items on your page.

 

if you use Scroll Header Pro to create page headings, just place this section between other sections. SNav will instantly create menu item for each. 

 

Also, if you don't want to show Scroll nav on every page, I advice to move SNav from header to the top of template area.

 

if anything else needed, please ask

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

hi.

 

I have taken out that other one and added titles in my scroll nav options but still nothing is showing for me.

 

what should I do next? do you want to login and see if there's something going on?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

awesome. 

 

that fixed me.

 

thanks,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now