Jump to content


Photo
Selettore Tabs

[pl_accordion] shortcode doesn't expand in Selettore Tabs



  • Please log in to reply
6 replies to this topic

#1 MrFent

MrFent

    Super Member

  • Members


  • 232 posts
  • Country: Country Flag

Posted 18 November 2013 - 02:21 AM

Hi, I'm trying to add the pl_accordion shortcode to the selettore tabs section in DMS. The accordion appears, but it doesn't expand when clicked on. I disabled all my other plugins except selettore tabs, but that didn't fix it. This error occurs both when I put the link in the HTML in the default settings, as well as when I link to an actual page that has the shortcode. Please advise.

 

Link with selettore tabs section:

http://store.culture...onnas-cultures/

 

Tabs 1-3 link to a page, one of them being http://store.culture...s-kefir-grains/ so you can see on that actual page, the accordion works as intended. 

 

Tab 4 has the [pl_accordion] shortcode directly in the Content Settings. 



#2 MrFent

MrFent

    Super Member

  • Members


  • 232 posts
  • Country: Country Flag

Posted 18 November 2013 - 07:16 AM

going into the section.php, I noticed that if I removed the follow div containers (and their closing divs) from the section_template:

 

 <div class="tab-wrapper" data-index="<?php echo $i ?>">
                        <div class="tab-label <?php echo $i == 0 ? 'current' : '' ?>">
 
If I remove these two lines (plus the closing divs at the bottom,) the selettore tabs go all screwy, but at least I can get the pl_accordion to work properly. So I'm thinking the issue has something to do with these two divs. Anyway, I hope this will save you some troubleshooting time. 


#3 tmeister

tmeister

    Super Member

  • Members

  • 168 posts
  • LocationValle de Bravo, México
  • Country: Country Flag

Posted 18 November 2013 - 03:34 PM

Hi,

 

i will take a look and back to you.

 

Best,

Enrique



#4 tmeister

tmeister

    Super Member

  • Members

  • 168 posts
  • LocationValle de Bravo, México
  • Country: Country Flag

Posted 18 November 2013 - 05:20 PM

Hi there,

 

The fix is ready, please update the 1.3.1 version.

 

The issue was the tab ID's, selettore clone the content to handle the mobile and the desk views and when the content was cloned the IDs was cloned too, creating the conflict, now when the content is cloned i add a suffix to the ids to keep then as unique ids, and that do the job.

 

Best,

Enrique. 



#5 MrFent

MrFent

    Super Member

  • Members


  • 232 posts
  • Country: Country Flag

Posted 18 November 2013 - 10:42 PM

Hi Enrique, thank you very much! That fixed it and everything is working great. One thing I noticed though is that I had to manually update the section by deleting it and re-uploading the new one. It never showed up in my wp updates, and before the 1.3 version I had been using the 1.1 version for several month, and no automatic updates. 

 

I LOVE this section, you did a great job. I'm plan on converting a site to DMS, and one of the big reasons for doing so is so I can use this section throughout it. If the review system ever goes back online in the store, I'll leave you a good one. Thanks again!

 

 

Chris



#6 faustus501

faustus501

    Newbie

  • Members

  • 8 posts
  • LocationSydney
  • Country: Country Flag

Posted 24 May 2014 - 09:44 AM

I am trying to open a pl_accordion from a link.

 

Idea is that footnotes are in accordion, when user clicks link denoting footnote page jumps to accordion and it opens, see below for code I am using.

 

Otherwise if user scrolls down page they come across accordion in closed state.

 

I have purchased the accordions section but am not using it, is way too convoluted, for this purpose. I have tried a number of other shortcode plugins, all of which I have come across are in conflict with DMS.

 

If there is no way to achieve this with pl_accordion could you recommend a shortcode plugin that wont break DMS?

 

Any help with is would be greatly appreciated.

 

Cheers!

 

<sup><a href="#footnote">[5]</a></sup>

 

[pl_accordion name="footnote"]

[pl_accordioncontent name="footnotes" number="1" heading="Footnotes" open="no"]

 
<ol>
</ol>
 
[/pl_accordioncontent]
[/pl_accordion]
 
Also, here is a site with the functionality I am trying to mimic - http://eex.gov.au/in...port/#fn-4232-1


#7 Martin Davies

Martin Davies

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 28 May 2014 - 11:47 AM

Hello @faustus501

 

Please create you own forum topic for this issue. This topic is from November 2013 







Also tagged with one or more of these keywords: Selettore Tabs